<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 12 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.StileMessaggioDiPostaElettronica17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 2.0cm 2.0cm 2.0cm;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=IT link=blue vlink=purple><div class=WordSection1><p class=MsoNormal><span lang=EN-US>Hi there,<br>I have an issue with glFlush, and I don’t know exactly if this is related to OSG.<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>Basically, I have a very complicated scenegraph, whose drawables are my own classes<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>derived from osg::drawable. So, they implement the drawImplementation, by using standard<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>OpenGL rendering commands (basically vertex arrays).<br><br><o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>I had to put a glFlush() at the end of each drawImplmentation() to make it work correctly.<br>I mean that, if I didn’t, the drawing would be completely wrong, as if wrong normals were applied<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>to lighting computations. But glFlush() should only flush the content of the command buffer to the graphic board.<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>Am I worng?<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>Furthermore, it does not behave wrongly on every graphic board, only some cards shows the problem<br>(mine is a nVidia Quadro FX 2500M).<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p><p class=MsoNormal><span lang=EN-US>What’s even worse is that putting such calls slows down my application a lot (from 22 to 13 fps).<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p><p class=MsoNormal><span lang=EN-US>So, I just wonder if it might be a problem related to OSG (since I mixed osg with direct OpenGL commands),<br>or if it might be related to specific drivers of my graphic board.<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p><p class=MsoNormal><span lang=EN-US>Thanks in advance,<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US>Gianluca<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p><p class=MsoNormal><span lang=EN-US>P.S. = BTW, if I replaced glFlush() with a double call to glPointSize(), passing 3.0 and 1.0 in sequence as sizes<br>           (but without making any other call inbetween). It still works good, as if glFlush() was issued, but without the<br>           side effect of slowness. So, actually they act as a glFlush() in my code!<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US> <o:p></o:p></span></p></div></body></html>