<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 11 (filtered medium)">
<!--[if !mso]>
<style>
v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style>
<![endif]-->
<style>
<!--
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman";}
a:link, span.MsoHyperlink
        {color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {color:blue;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-reply;
        font-family:Arial;
        color:navy;}
@page Section1
        {size:595.3pt 841.9pt;
        margin:1.0in 1.25in 1.0in 1.25in;}
div.Section1
        {page:Section1;}
-->
</style>

</head>

<body lang=EN-US link=blue vlink=blue>

<div class=Section1 dir=RTL>

<p class=MsoNormal dir=LTR><font size=2 color=navy face=Arial><span
style='font-size:10.0pt;font-family:Arial;color:navy'>So maybe it should be
decided by a flag from the user, or by the tile size… if it fits in
short, use it for performance, else use int?<o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=2 color=navy face=Arial><span
style='font-size:10.0pt;font-family:Arial;color:navy'><o:p> </o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=2 color=navy face=Arial><span
style='font-size:10.0pt;font-family:Arial;color:navy'>Guy.<o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=2 color=navy face=Arial><span
style='font-size:10.0pt;font-family:Arial;color:navy'><o:p> </o:p></span></font></p>

<div>

<div class=MsoNormal align=center dir=LTR style='text-align:center'><font
size=3 face="Times New Roman"><span style='font-size:12.0pt'>

<hr size=2 width="100%" align=center tabindex=-1>

</span></font></div>

</div>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'><o:p> </o:p></span></font></p>

<p class=MsoNormal dir=LTR style='margin-bottom:12.0pt'><font size=3
face="Times New Roman"><span style='font-size:12.0pt'>Hi Martins,<br>
<br>
Good catch.  Use of DrawElementUint will provide better scalability in
terms of tile size, but DrawElementUShort will still be preferred by default as
it'll provide better performance.  Also small tiles sizes are to be
preferred for other performance aspects.<br>
<br>
Robert.<o:p></o:p></span></font></p>

<div>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'>On Tue, Mar 24, 2009 at 7:14 PM, Martins Innus <<a
href="mailto:minnus@ccr.buffalo.edu">minnus@ccr.buffalo.edu</a>> wrote:<o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'>Robert,<br>
<br>
       It seems that this issue is caused by the use of
DrawElementsUShort and "unsigned short" indexes in "osg::Node*
DestinationTile::createPolygonal()".  Such that each level can only
have a maximum of 65536 vertexes.  And I do see that a terrain-tile size
of 256x256 works, yet 512x12 doesn't, which makes sense.<br>
<br>
       Is this something you'd accept a change for to be
included in VPB?  Not sure what the performance implications would be, or
how extensive the changes would need to be.<br>
<font color="#888888"><span style='color:#888888'><br>
Martins</span></font><o:p></o:p></span></font></p>

<div>

<div>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'><br>
<br>
Martins Innus wrote:<o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'>Robert,<br>
   What fun would it be if people didn't abuse your code :)  I
agree that in general VPB does a great job with default settings, I've used it
several times to generate 100 GB databases over large areas.<br>
<br>
   In this case though I'm trying to generate terrain at the
resolution of the source data for a very small area in as few tiles as
possible. I realize this is not the intended purpose, but I was trying to see
if anyone had done this successfully.<br>
<br>
   It doesn't seem to be a display issue, becase I can generate the
model with default options and load all the highest resolution tiles directly
into osgviewer and it runs fine, about 4 million vertices.<br>
<br>
   Going down to 512x512 causes the same problem.<br>
<br>
   I'll keep digging if no one has run into this before.<br>
<br>
Martins<br>
<br>
Robert Osfield wrote:<o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'>Hi Martins,<br>
<br>
Jikes, some days I regret making osgdem quite so flexible...<br>
<br>
A 1024x1204 grid weights in at million vertices, and near two million
triangles.  Normally graphics cards should be able to handle this, but...
it would seem that your's doesn't, perhaps it just doesn't have the memory to
handle such a big geometry.  The other chance might be that numerical
precision is becoming an issue, although I'd be surprised by this one.<br>
<br>
I really would very strongly recommend that you stick to defaults unless you
really know what you are doing, the defaults are chosen for a good performance
and scalability.<br>
<br>
Robert.<br>
<br>
2009/3/23 Martins Innus <<a href="mailto:minnus@ccr.buffalo.edu"
target="_blank">minnus@ccr.buffalo.edu</a> <mailto:<a
href="mailto:minnus@ccr.buffalo.edu" target="_blank">minnus@ccr.buffalo.edu</a>>><br>
<br>
   Hello,<br>
          I'm using the --tile-image-size and
--tile-terrain-size<br>
   options to tweak the generation of the dataset.  The image
option<br>
   works great, but when I try to use the terrain option I get the<br>
   results attached.<br>
<br>
          If I zoom in, it seems like a lot of
overlapping geometry<br>
   like the y-coordinate is not being updated properly, but I dug<br>
   through the code and could see any obvious causes.<br>
<br>
   I'm using the following command-line:<br>
<br>
   osgdem --tile-image-size 4096 --tile-terrain-size 1024 -t<br>
   ../input_ims/ -d ../input_terrain/ -e 1065536 1043840 8192 8192 -o<br>
   output/vpb_out.ive<br>
<br>
   I even added --no-terrain-simplification to see if that was the<br>
   problem, but no help there.<br>
<br>
          I'm not using the --TERRAIN option, since I
need to<br>
   post-process the geometry using an existing tool.<br>
<br>
   Thanks<br>
<br>
   Martins<br>
<br>
   _______________________________________________<br>
   osg-users mailing list<br>
   <a href="mailto:osg-users@lists.openscenegraph.org" target="_blank">osg-users@lists.openscenegraph.org</a><br>
   <mailto:<a href="mailto:osg-users@lists.openscenegraph.org"
target="_blank">osg-users@lists.openscenegraph.org</a>><br>
   <a
href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org"
target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><br>
<br>
<br>
<br>
------------------------------------------------------------------------<br>
<br>
_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org" target="_blank">osg-users@lists.openscenegraph.org</a><br>
<a
href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org"
target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'>_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org" target="_blank">osg-users@lists.openscenegraph.org</a><br>
<a
href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org"
target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><o:p></o:p></span></font></p>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'>_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org" target="_blank">osg-users@lists.openscenegraph.org</a><br>
<a
href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org"
target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><o:p></o:p></span></font></p>

</div>

</div>

</div>

<p class=MsoNormal dir=LTR><font size=3 face="Times New Roman"><span
style='font-size:12.0pt'><o:p> </o:p></span></font></p>

</div>

</body>

</html>