I was wondering about that - thanks for the tip,<br>Richard<br><br><br><div class="gmail_quote">On Wed, Mar 18, 2009 at 3:04 AM, Fernan <span dir="ltr"><osgforum@tevs.eu></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi Robert,<br>
<br>
Thank you for your help.<br>
I've achieved my purpose.<br>
<br>
Following your instructions I realized that my problems were two:<br>
<br>
1) On the one hand, the scene by default sets the AmbientIntensity as follows:<br>
<br>
        osg::LightModel* lightmodel = new osg::LightModel;<br>
        lightmodel->setAmbientIntensity(osg::Vec4(0.1f,0.1f,0.1f,1.0f));<br>
        _globalStateSet->setAttributeAndModes(lightmodel, osg::StateAttribute::ON);<br>
<br>
And due this the scene was always a little light.<br>
Then I set this value to zero in my application after create the scene:<br>
<br>
        osg::LightModel* lightmodel = new osg::LightModel;<br>
        lightmodel->setAmbientIntensity(osg::Vec4(0.0f,0.0f,0.0f,1.0f));<br>
        _globalStateSet->setAttributeAndModes(lightmodel, osg::StateAttribute::ON);<br>
<br>
And I got all the elements of the scene appear dark unless sea.<br>
<br>
2) On the other, I realized that I was applying to the sea surface an OSG::Material with Emission value set to nonzero. Once I set the zero value to this parameter, all to be completely dark in my scene.<br>
<br>
------<br>
<br>
I leave here my solution in order to it can help someone with same problem.<br>
<br>
Thanks a lot again for your help.<br>
<div class="im"><br>
------------------<br>
Read this topic online here:<br>
</div><a href="http://forum.openscenegraph.org/viewtopic.php?p=8627#8627" target="_blank">http://forum.openscenegraph.org/viewtopic.php?p=8627#8627</a><br>
<div><div></div><div class="h5"><br>
<br>
<br>
<br>
<br>
_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org">osg-users@lists.openscenegraph.org</a><br>
<a href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org" target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><br>
</div></div></blockquote></div><br>