Hi Martins,<br><br>Jikes, some days I regret making osgdem quite so flexible...<br><br>A 1024x1204 grid weights in at million vertices, and near two million triangles.  Normally graphics cards should be able to handle this, but... it would seem that your's doesn't, perhaps it just doesn't have the memory to handle such a big geometry.  The other chance might be that numerical precision is becoming an issue, although I'd be surprised by this one.<br>
<br>I really would very strongly recommend that you stick to defaults unless you really know what you are doing, the defaults are chosen for a good performance and scalability.<br><br>Robert.<br><br><div class="gmail_quote">
2009/3/23 Martins Innus <span dir="ltr"><<a href="mailto:minnus@ccr.buffalo.edu">minnus@ccr.buffalo.edu</a>></span><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hello,<br>
        I'm using the --tile-image-size and --tile-terrain-size options to tweak the generation of the dataset.  The image option works great, but when I try to use the terrain option I get the results attached.<br>
<br>
        If I zoom in, it seems like a lot of overlapping geometry like the y-coordinate is not being updated properly, but I dug through the code and could see any obvious causes.<br>
<br>
I'm using the following command-line:<br>
<br>
osgdem --tile-image-size 4096 --tile-terrain-size 1024 -t ../input_ims/ -d ../input_terrain/ -e 1065536 1043840 8192 8192 -o output/vpb_out.ive<br>
<br>
I even added --no-terrain-simplification to see if that was the problem, but no help there.<br>
<br>
        I'm not using the --TERRAIN option, since I need to post-process the geometry using an existing tool.<br>
<br>
Thanks<br><font color="#888888">
<br>
Martins<br>
</font><br>_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org">osg-users@lists.openscenegraph.org</a><br>
<a href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org" target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><br>
<br></blockquote></div><br>