Hi John,<br><br>This does sounds like a CMake bug.  I wonder if reverting to old version of CMake might help.<br><br>Robert.<br><br><div class="gmail_quote">On Wed, Mar 18, 2009 at 8:17 PM, john casu <span dir="ltr"><<a href="mailto:john@chiraldynamics.com">john@chiraldynamics.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Robert,<br>
<br>
I put debugging messages in FindFreeType.cmake, and the behavior is as expected within that cmake file, i.e. FREETYPE_INCLUDE_DIRS gets set correctly.<br>
<br>
The issue, as far as I can tell, is why cmake on os/x either isn't exporting FREETYPE_INCLUDE_DIRS, or there's a typo somewhere outside that file so that the variable isn't getting picked up.<br>
<br>
I spent a little time trying to debug this, but I'm not really getting anywhere, given that I have little cmake experience.  But, everything does seem to be working as expected, so it's a little bit of a mystery.<br>

<br>
certainly, the code in Find3rdPartyDependencies.cmake doesn't seem to be traversed, and src/osgPlugins/freetype/CMakeLists.txt seems to be correct.<br>
<br>
Unfortunately, I don't have enough time, right now, to devote to debugging this in any depth.   And since I do have a workaround, I'm not blocked.<br>
<div class="im"><br>
------------------<br>
Read this topic online here:<br>
</div><a href="http://forum.openscenegraph.org/viewtopic.php?p=8734#8734" target="_blank">http://forum.openscenegraph.org/viewtopic.php?p=8734#8734</a><br>
<div><div></div><div class="h5"><br>
<br>
<br>
<br>
<br>
_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org">osg-users@lists.openscenegraph.org</a><br>
<a href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org" target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><br>
</div></div></blockquote></div><br>