Hi Peter,<br><br><div class="gmail_quote">On Tue, Mar 17, 2009 at 9:30 AM, petr <span dir="ltr"><osgforum@tevs.eu></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
first q:<br>
--------<br>
I have got in a root group tree nodes<br>
1st - the scene (cca 300 triangulates+7 types of textures )<br>
2nd - the tank t72-tank_des.flt<br>
3rd - the personal car (very simple cca 200 triangulates)<br>
two cameras - one is fulscreen, the second is small rectangle in the midle of the screen on the top.<br>
<br>
Could you you explain me why the view is discontinuous (the quality is very(!) terrible) ?<br>
I have found that when I'am using the only camera - like fullscreen, the discontinous view can be "removed" by these function viewer->startThreading(); - the quality is absolutely briliant!<br>
Could you explain me what does it mean "threading", this word is in a dictionary - of course, but i would like to know what does the function do in osg. - or what does it "looking after" ...</blockquote>
<div><br>I can't see how we could answer this without at least a screenshot of what you mean by "discontinuous", and what you expect the result to look like.<br> </div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
second q:<br>
-----------<br>
Why does a nodes take so long to load?  For example - first node the scene takes in Vega cca 3-4 seconds and now in OSG it takes cca 15 sec.<br>
(The one our big scene cca 20 000t is loaded by 10sec in Vega, but in Osg it takes almost 1 min)</blockquote><div><br>Try converting your models to native OSG format.  OpenFlight really sucks for loading performance as the database requires a lot of pre-processing to get into a shape that is suitable for rendering.   I would strongly recommend converting to .ive for any visual simulation app.<br>
<br> </div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
pc config:<br>
cpu: Intel 3.2Ghz<br>
Grapic card: GeForce 7600GT/PCI/SSE2, 256MB ram, silent pipe<br>
Monitor resolution: 1280x1024<br>
rendering test by OpenGL Extension Viewer 3.0:<br>
1.1 109 FPS<br>
2.0 104 FPS<br>
2.1 066 FPS<br>
<br>
Thanks a lot for your replies.<br>
</blockquote></div><br>I have no clue what your above 1.1 109 FPS stats relate to, is it anything to do with the OSG?<br><br>Robert.<br>