<div dir="ltr">Hi Ravi,<br><br>I submitted a fix for this but it didn't make it into the 2.6 release.  Moving to the trunk should fix the problem.  I also don't think this made it into the 2.6 maintainence branch either, perhaps it should?<br>
<br>Thanks!<br><br>Jason<br><br><div class="gmail_quote">On Thu, Sep 11, 2008 at 2:19 PM, Rahul Jain <span dir="ltr"><<a href="mailto:rahulj@vizexperts.com">rahulj@vizexperts.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>
Hi All,<br>
I am trying to set Render target implementation  using function setRenderTargetImplementation() in my application but it is not changing, When i looked in to the code I found out that the init() function is called in constructor, which in turn calls function getOverlayData(); for the first time, where default _renderTargetImpl(FBO) is set.<br>

           Now if i call the function "setRenderTargetImplementation()" for changing render target implementation, it again calls getOverlayData(0), function returns without doing anything as OverlayData is already created for "cv = 0". <br>

I am using OSG 2.6. Am i missing something or this might be a bug.<br>
Best regards,<br>
Rahul<br>
<br>
-- <br>
Rahul Jain,<br>
Member of Technical Staff,<br>
Visualization Experts Limited.<br>
<a href="http://www.vizexperts.com" target="_blank">www.vizexperts.com</a><br>
+91-98109-83697 (M) <br>
_______________________________________________<br>
osg-users mailing list<br>
<a href="mailto:osg-users@lists.openscenegraph.org" target="_blank">osg-users@lists.openscenegraph.org</a><br>
<a href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org" target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</a><br>
</blockquote></div><br></div>