<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman, new york, times, serif;font-size:12pt"><DIV>Hi Steffen, Guay and Robert,</DIV>
<DIV> </DIV>
<DIV>   In the same regard I would like to mention something. We have also developed an application that uses multiple RTT cameras. However only one camera is active at a time ( the rest are masked using node mask). All cameras differ only in the resolution of the texture, they are viewing exactly the same scene and have identical fields of view. We too have found that the frame rate has a lot of dependence on the texture size. 256 x256 texture gives a fairly high frame rate(30+ frames/second), 512x512 slows it down considerably (to around 8 frames / second) and 1024x1024 slows it even further (~ 1 fps). All these figures are in release mode build.</DIV>
<DIV> </DIV>
<DIV>My machine specifications</DIV>
<DIV>Processor:     Xeon 5160</DIV>
<DIV>RAM:            4 GB Fully Buffered DDR2</DIV>
<DIV>Graphics:        nVidia Quadro FX4500 (512MB)</DIV>
<DIV> </DIV>
<DIV>    I would be highly obliged if a way out can be suggested.</DIV>
<DIV> </DIV>
<DIV>Regards</DIV>
<DIV> </DIV>
<DIV>Harash  </DIV>
<DIV style="FONT-SIZE: 12pt; FONT-FAMILY: times new roman, new york, times, serif"><BR>
<DIV style="FONT-SIZE: 13px; FONT-FAMILY: arial, helvetica, sans-serif">----- Original Message ----<BR>From: Steffen Kim <mailto.stk@web.de><BR>To: osg-users@lists.openscenegraph.org<BR>Sent: Friday, September 5, 2008 10:04:25 PM<BR>Subject: Re: [osg-users] performance issues with RTT<BR><BR>Thanks for the hints so far...<BR><BR>I gave you wrong information since I forgot that I take care of the NPOT-stuff myself.<BR>The API I use later on needs POT-textures so I make sure that only POT-textures are rendered. So in fact my textures are normally 2048x1024.<BR><BR>I know that the performance issues are most certain a problem of the texture rendering since we have parts of the application where even huger amounts of (normal render-to-view) cameras are involved without slowing down everything as much. The scene is pretty simple too and runs smoothly without the RTT-cameras.<BR>Back on Monday I will try to get some FPS-values for exactly the same
 camera-setup with and without RTT for different scene complexities (here in Germany the weekend begins now ;)).<BR><BR>What I just found out is that the texture sizes make a huge difference in rendering performance. With 256x256-textures my cameras hardly slow down the viewer at all. That's also an evidence that the problem has to be somewhere in the texture-creation-part. <BR>If this cannot be enhanced then I probably have to find a good balance between quality and speed.<BR>But I still have hopes that there are better ways to improve my performance without having to sacrifice too much resolution-wise.<BR><BR>BTW: I'm running my stuff on a Xeon 5160 at 3GHz and 2GB RAM with a Radeon X1900 card.<BR><BR>Have a nice weekend,<BR>Steffen<BR><BR><BR><BR>_______________________________________________________________________<BR>Jetzt neu! Schützen Sie Ihren PC mit McAfee und <A href="http://web.de/" target=_blank>WEB.DE</A>. 30 Tage<BR>kostenlos testen. <A
 href="http://www.pc-sicherheit.web.de/startseite/?mc=022220" target=_blank>http://www.pc-sicherheit.web.de/startseite/?mc=022220</A><BR><BR>_______________________________________________<BR>osg-users mailing list<BR><A href="mailto:osg-users@lists.openscenegraph.org" ymailto="mailto:osg-users@lists.openscenegraph.org">osg-users@lists.openscenegraph.org</A><BR><A href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org" target=_blank>http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org</A><BR></DIV></DIV></div><br>



      </body></html>