<div dir="ltr">On Mon, Jul 21, 2008 at 7:45 AM, Serge Lages <<a href="mailto:serge.lages@gmail.com">serge.lages@gmail.com</a>> wrote:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div dir="ltr">Hi Philip,<br><br>I added this option some time ago, and VS9 wasn't still available. So feel free to update it and add VS9. As a side note, is it possible to make a condition like "all VS versions superiors to 8" ?<br>

<br><div class="gmail_quote"><div><div></div><div class="Wj3C7c">On Mon, Jul 21, 2008 at 1:31 PM, Philip Lowman <<a href="mailto:philip@yhbt.com" target="_blank">philip@yhbt.com</a>> wrote:<br></div></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div><div></div><div class="Wj3C7c">
<div dir="ltr">I was looking for something else and came across this in src/CMakeLists.txt and it looked a little odd.  I thought I would ask the question if this was meant to apply to VS9 as well?  If so, MSVC_VERSION should probably be used here.<br>


<br>IF(MSVC80)<br>  OPTION(OSG_MSVC_GENERATE_PLUGINS_AND_WRAPPERS_MANIFESTS "Generate or not manifests files under VS8 for dynamically loaded dlls" ON)<br>ENDIF(MSVC80)</div></div></div></blockquote></div></div>
</blockquote><div><br>I think this might work although I can't test (either if this conditional will work or if manifest generation on MSVC9 will work properly)<br><br>IF(MSVC_VERSION EQUAL 1400 OR <br>    MSVC_VERSION GREATER 1400)<br>
   # do stuff<br><br><a href="http://predef.sourceforge.net/precomp.html#sec32">http://predef.sourceforge.net/precomp.html#sec32</a><br><br></div></div>-- <br>Philip Lowman
</div>