<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:SimSun;
        panose-1:2 1 6 0 3 1 1 1 1 1;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:"\@SimSun";
        panose-1:2 1 6 0 3 1 1 1 1 1;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:SimSun;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.postbody
        {mso-style-name:postbody;}
span.EmailStyle19
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page Section1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body lang=EN-US link=blue vlink=purple>

<div class=Section1>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>This is a compiler problem not an OSG problem, so you really
need to ask Microsoft, it’s a problem with their compiler and code not
OSG<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p> </o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p> </o:p></span></p>

<p class=MsoNormal><span style='font-size:7.5pt;font-family:"Courier New";
color:#1F497D'>__________________________________________________________<br>
</span><i><span style='font-size:7.5pt;font-family:"Courier New";color:blue'>Gordon
Tomlinson </span></i><span style='font-size:7.5pt;font-family:"Courier New";
color:blue'><br>
<br>
</span><span style='font-size:7.5pt;font-family:"Courier New";color:#1F497D'>__________________________________________________________</span><span
style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p> </o:p></span></p>

<div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'>

<p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span></b><span
style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>
osg-users-bounces@lists.openscenegraph.org
[mailto:osg-users-bounces@lists.openscenegraph.org] <b>On Behalf Of </b>heishuijing_2000<br>
<b>Sent:</b> Monday, July 14, 2008 9:32 PM<br>
<b>To:</b> osg-users@lists.openscenegraph.org<br>
<b>Subject:</b> [osg-users] memory leak about osg MFC project AGAIN<o:p></o:p></span></p>

</div>

<p class=MsoNormal><o:p> </o:p></p>

<div>

<p class=MsoNormal>hi,<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal>    I am sorry to ask about this topic
again,:). I have asked the same question before. That's about osgMFC
example. Somebody in this email List have help me with it. And that's perfect.<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal style='margin-bottom:12.0pt'><span class=postbody><span
style='font-size:10.0pt'>>>There is a known issue/BUG with MFC, were MFC
makes a call to </span></span><span style='font-size:10.0pt'><br>
<span class=postbody>>>_CrtDumpMemoryLeaks() in the destructor of the
_AFX_DEBUG_STATE, followed by _CrtSetDbgFlag() which sets it to
~_CRTDBG_LEAK_CHECK_DF (therefor >>disabling memory leak test at *true*
program exit) This destructor is called at exit (i.e. atexit()), but before
statics residing in dlls and >>others are destroyed, resulting in many
false memory leaks are reported </span></span><o:p></o:p></p>

</div>

<div>

<p class=MsoNormal>    I use VS2003 and osg2.4 in debug
mode. In my project, i Just add mfc71d.lib before all of the osg Libs ,and the
VS no longer report memory.<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal>     <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal>    Unfortunately,recently the project report
memory leak again. That is about osgUtil::Tessellator,Here is my test code:<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //the test code is drawing a concave like a rect
containing a triangle with it .The Rect and the triangle intersect with one
point,as <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //we can see bellow<o:p></o:p></p>

</div>

<div>

<div>

<p class=MsoNormal> //an concave polygon <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //   *******************************<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //  
*            *
*             
*<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //  
*          
*   *            
*<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //  
*         
*    
*            *<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //  
*        
*      
*           *<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //   *       
***********          *<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //  
*                            
*<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> //   *******************************<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

</div>

<div>

<p class=MsoNormal> osgViewer::Viewer viewer;<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> osg::ref_ptr< osg::Vec3Array > vertices = new
osg::Vec3Array;<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> vertices->push_back(osg::Vec3(-100,0,-100));<br>
 vertices->push_back(osg::Vec3(100,0,-100));<br>
 vertices->push_back(osg::Vec3(100,0,100));<br>
 <strong><span style='font-family:SimSun'>vertices->push_back(osg::Vec3(0,0,100));</span></strong><b><br>
</b> vertices->push_back(osg::Vec3(50,0,50));<br>
 vertices->push_back(osg::Vec3(-50,0,50));<br>
 <strong><span style='font-family:SimSun'>vertices->push_back(osg::Vec3(0,0,100));</span></strong><br>
 vertices->push_back(osg::Vec3(-100,0,100));<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> osg::ref_ptr< osg::Vec3Array > pNormal = new
osg::Vec3Array();<br>
 pNormal->push_back(osg::Vec3(0,-1,0));<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal><br>
 osg::ref_ptr <osg::Geometry> geom = new osg::Geometry;<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal><br>
 geom->setVertexArray(vertices.get());<br>
 geom->setNormalArray(pNormal.get());<br>
 geom->setNormalBinding(osg::Geometry::BIND_OVERALL);<br>
 geom->addPrimitiveSet(new
osg::DrawArrays(osg::PrimitiveSet::POLYGON,0,vertices->size()));<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> osg::ref_ptr< osgUtil::Tessellator > tes = new
osgUtil::Tessellator();<br>
 tes->setTessellationType(osgUtil::Tessellator::TESS_TYPE_GEOMETRY);<br>
 tes->setBoundaryOnly(false);<br>
 tes->setWindingType( osgUtil::Tessellator::TESS_WINDING_ODD);<br>
 tes->retessellatePolygons(*geom);<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> osg::ref_ptr<osg::Geode> geode = new osg::Geode;<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> geode->addDrawable(geom.get());<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> osg::ref_ptr<osg::Group> pGroup = new
osg::Group;<br>
 pGroup->addChild(geode.get());<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal><br>
 viewer.setSceneData( pGroup.get() );<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> I test this code in non-MFC project such as console
project,that works perfect.No memory leak is reported. But when i turn to
osg  MFC project,the VS always reports memory leak . I notice that if the
polygon is <strong><span style='font-family:SimSun'>self-intersect ,</span></strong>there
must be memory leak report in MFC project.<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> <o:p></o:p></p>

</div>

<div>

<p class=MsoNormal> I really do not know how to do about it . I just want
to find a method to prevent the VS reprot false memory leak. Anyone
help me? Thank you ,:)<o:p></o:p></p>

</div>

</div>

</body>

</html>