<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=us-ascii">
<META content="MSHTML 6.00.6000.16674" name=GENERATOR></HEAD>
<BODY>
<DIV dir=ltr align=left><SPAN class=921524121-01072008><FONT face=Arial 
size=2>Do you get the same behavior if you generate fresh VS9 project files with 
cmake, instead of generating VS7.1 files and converting them? I'm not sure this 
will have any effect, but it seems like it might be worth a 
shot...</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=921524121-01072008><FONT face=Arial 
size=2>   -Paul</FONT></SPAN></DIV>
<DIV dir=ltr align=left><SPAN class=921524121-01072008></SPAN> </DIV><BR>
<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV class=OutlookMessageHeader lang=en-us dir=ltr align=left>
  <HR tabIndex=-1>
  <FONT face=Tahoma size=2><B>From:</B> 
  osg-users-bounces@lists.openscenegraph.org 
  [mailto:osg-users-bounces@lists.openscenegraph.org] <B>On Behalf Of </B>Rick 
  Pingry<BR><B>Sent:</B> Tuesday, July 01, 2008 3:14 PM<BR><B>To:</B> 
  OpenSceneGraph Users<BR><B>Subject:</B> [osg-users] Performance hit caused by 
  porting from VS 7.1 to VS 9<BR></FONT><BR></DIV>
  <DIV></DIV>
  <DIV>Hello All,<BR> <BR>We have succesfully ported from OSG 1.2 to the 
  newest SVN version (well, almost newest, I think we are on 8512 at the 
  moment).  Thanks again for all the fantastic forum 
  support.<BR> <BR>We have been using VS 7.1 for all of our work so far, 
  but since we were missing a well build freetype library, I figured it was time 
  to make the jump there as well.  I downloaded VS 9 express and ran CMake 
  to build OSG.  All built just fine.  The converter in VS 9 converted 
  all of the projects without fuss, and I was able to get it all compiling and 
  running pretty easily.  Unfortunately, I am seeing this 30% drop in 
  framerate :(.  I was seeing about 28-30 fps (yes, I know, I have some 
  scene optimizing to do) with the VS 7.1 build, which dropped to 20-21 fps 
  using VS 9 express.<BR> <BR>Has anyone seen anything like that 
  before?  Am I missing some setting somewhere?  Perhaps the converter 
  in VS 9 does not like me?<BR></DIV>
  <DIV>Any ideas?</DIV>
  <P>-- Thanks<BR>>> Rick<BR>Check us out at <A 
  href="http://fringe-online.com/">http://fringe-online.com/</A></P></BLOCKQUOTE></BODY></HTML>