Hi Andre,<br><br>I'm actually still using OSG 1.2 with Producer, so anything in osgViewer shouldn't be the issue I'm seeing.  All other windows and menus seem to work fine.  The only issue I'm seeing this with is ToolTips.  Thanks for your help!
<br><br>Jason<br><br><div><span class="gmail_quote">On 10/3/07, <b class="gmail_sendername">André Garneau</b> <<a href="mailto:andre@pixdev.com">andre@pixdev.com</a>> wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">









<div link="blue" vlink="purple" lang="EN-CA">

<div>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);">Hi Jason,</span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);"> </span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);">When a graphics window (Win32) is created, it is set by default to
be at the top of the windows Z-order. This is done at line 1629 of
GraphicsWindowWin32.cpp, i.e.</span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);"> </span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);">if (!::SetWindowPos(_hwnd, <b>HWND_TOP</b>,
_windowOriginXToRealize,...))</span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);"> </span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);">You might want to check using other values for the second
parameter (replacing HWND_TOP with either HWND_BOTTOM</span><span style="font-size: 11pt; color: rgb(31, 73, 125);" lang="EN-US"> or </span><span style="font-size: 11pt; color: rgb(31, 73, 125);">HWND_NOTOPMOST)
to see if it resolves the issue in your application while still allowing the
window content to be visible relative to other windows.</span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);"> </span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);">André</span></p>

<p><span style="font-size: 11pt; color: rgb(31, 73, 125);"> </span></p>

<div style="border-style: solid none none; border-color: rgb(181, 196, 223) -moz-use-text-color -moz-use-text-color; border-width: 1pt medium medium; padding: 3pt 0cm 0cm;">

<p><b><span style="font-size: 10pt;" lang="EN-US">From:</span></b><span style="font-size: 10pt;" lang="EN-US"> <a href="mailto:osg-users-bounces@lists.openscenegraph.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
osg-users-bounces@lists.openscenegraph.org</a>
[mailto:<a href="mailto:osg-users-bounces@lists.openscenegraph.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">osg-users-bounces@lists.openscenegraph.org</a>] <b>On Behalf Of </b>Jason
Beverage<br>
<b>Sent:</b> October-03-07 12:23 PM<br>
<b>To:</b> osg users<br>
<b>Subject:</b> [osg-users] Problems with Overriding Tooltips on Windows</span></p>

</div><div><span class="e" id="q_11566cc7efe7f968_1">

<p> </p>

<p>Hi all,<br>
<br>
I've had a long standing issue with tooltips on some Windows XP machines that
we deploy our systems to.  If the tooltip text overlaps the OpenSceneGraph
window and the OpenSceneGraph window is redrawn, the tooltip is cut off and
invisible.  I've attached a small image of the problem in our
application.  The tooltip should say "Import Geospatial Data"
but because the OpenSceneGraph window (black area) overlaps the tooltip, it is
cut off. <br>
<br>
This seems to happen on NVidia systems mostly, updating to the latest drivers
doesn't seem to help at all.  Turning off Hardware Acceleration completely
in Windows causes the tooltips to work correctly, but my application runs
terribly slow (obviously:)) without OpenGL acceleration.  It should be noted
as well that this occurs in any OpenGL application I've tried, not just
OpenSceneGraph.  I was hoping someone here had the same experience and
found some workaround. <br>
<br>
Thanks!<br>
<br>
Jason</p>

</span></div></div>

</div>


<br>_______________________________________________<br>osg-users mailing list<br><a onclick="return top.js.OpenExtLink(window,event,this)" href="mailto:osg-users@lists.openscenegraph.org">osg-users@lists.openscenegraph.org
</a><br><a onclick="return top.js.OpenExtLink(window,event,this)" href="http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org" target="_blank">http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
</a><br><br></blockquote></div><br>