[osg-users] broken osgconv.exe

ted morris ted.morris at gmail.com
Fri Nov 27 15:28:21 PST 2009


hmmmmm.... well thought I did do that. I am able to get it all working on
another PC without installing 2005 *SP1*. just VC90 installed.

thanks, & have a good weekend.

-T

<snip>
I think you didn't install the 2005 *SP1* redistribuable package
(http://www.microsoft.com/downloads/details.aspx?FamilyID=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en)
.\
<snip>

On Wed, Nov 25, 2009 at 3:24 AM, Mourad Boufarguine <
mourad.boufarguine at gmail.com> wrote:

> Ted,
>
> I downloaded the osg precompiled package you are using (openscenegraph-all-2.8.2-win32-x86-vc90-Release.zip),
> and I checked that indeed, the osgdb_ive.dll depends on a zlib1.dll that was
> compiled with VS 2005 SP1 (which is weird). I presume it is also the case of
> libpng, curl and tiff.
>
> So, to move on, you have to recompile osg from the sources using the vc90
> dependencies, or install the VC++ 2005 redistribuable packages (there are
> two if my memory serves me right ), I think you didn't install the 2005 *
> SP1* redistribuable package
> (http://www.microsoft.com/downloads/details.aspx?FamilyID=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en)
> .
>
> Regards,
> Mourad
>
> On Tue, Nov 24, 2009 at 9:03 PM, ted morris wrote:
>
>>
>> Yes, I think I resolved finding the 3rdparty dependencies. But for some
>> reason, the osgdb_xxx pluggins listed in the last e-mail:
>>
>> osgdb_gz
>> osgdb_curl
>> osgdb_ive
>> osgdb_png
>> osgdb_tiff
>> osgdb_tiffd
>>
>> dependencywalker shows that these pluggin dlls are still looking for
>> MSVCR80.DLL  *and* MSVCR90.DLL
>>
>> And the other pluggins can't find MSVCR90.DLL.
>>
>> bizarre.
>>
>> thanks,
>> t
>>
>>
>>
>> Well, I tried dependencywalker.com and opened up the pluggins.
>>
>> On Mon, Nov 23, 2009 at 7:24 PM, Mourad Boufarguine <> wrote:
>>
>>>  Hi Ted,
>>>
>>> You can use the Dependency Walker (http://www.dependencywalker.com/) to
>>> check the version number of the runtime, the dependencies were compiled
>>> against.
>>>
>>> I just tried it with the zlib and png dlls contained in "VisualStudio 9
>>> (2008) SP1" prebuild dependencies (
>>> http://www.openscenegraph.org/projects/osg/wiki/Downloads/Dependencies),
>>> and I found that the release versions were compiled with the 9.0.30729
>>> runtime, which is actually "2008 SP1". The debug version, though, was
>>> compiled with the 9.0.21022 runtime , which is the "2008" runtime. The zlib
>>> is used in both ive and gz plugins. I don't see  how you get the message
>>> about the 2005 runtime dependency. Double check in the "output" window of VS
>>> that the zlib and png dlls that are actually loaded are the good ones.
>>>
>>> Regards,
>>> Mourad
>>>
>>> On Tue, Nov 24, 2009 at 1:21 AM, ted morris <> wrote:
>>>
>>>> credist_x86 VisualStudio 2005 (v8) runtimes
>>>
>>>
>>>
>>> _______________________________________________
>>> osg-users mailing list
>>> osg-users at lists.openscenegraph.org
>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>
>>>
>>
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091127/d1533e22/attachment.htm>


More information about the osg-users mailing list