[osg-users] [osgOcean] 3D model material display error!

Kim Bale kcbale at googlemail.com
Tue Nov 24 11:54:33 PST 2009


Hi Tian,

Sorry about the late reply on this, I must have got distracted and
forgot to reply.

> But the model was under a pisitionAttitudeNode, and I just make the model -1 meter down. Does it matter?

No that shouldn't matter, transforming the ocean surface itself may
cause problems though.

It's possible that one side of the model is being culled in the
reflection and you're seeing the inside of the model. I just added an
override to the reflection camera that should force face culling to
off when it's passing through the reflection camera
(http://code.google.com/p/osgocean/source/detail?r=184). This might
fix the problem, could you try updating from the trunk and see if the
issue is resolved?

Cheers.

K.


2009/11/24 Tian Ma <tianxiao888 at foxmail.com>:
> Hi Kim:
>
> No, I am not.
>
> But the model was under a pisitionAttitudeNode, and I just make the model -1 meter down. Does it matter?
>
> When go near the model, the reflection will be more and more cmoplete and looks like many triangle reflections combined together.
>
> The picture is as follow link:
>
> http://storage.openlab.net.cn/forums/2009-11-19/1981569/%e5%80%92%e5%bd%b1%e9%97%ae%e9%a2%98.jpg
> Cheers,
> MT
>
>
>
>
>
> Kim Bale wrote:
>> Are you using a matrix transform above OceanScene to alter the sea level?
>>
>> K.
>>
>>
>> 2009/11/19 Tian Ma <>:
>>
>> > Hi Kim:
>> >
>> > I just give the picture's URL link below:
>> >
>> > http://storage.openlab.net.cn/forums/2009-11-19/1981569/%e5%80%92%e5%bd%b1%e9%97%ae%e9%a2%98.jpg
>> >
>> > Cheers,
>> > MT
>> >
>> >
>> >
>> > Kim Bale wrote:
>> >
>> > > There's no attachment at all now :(
>> > >
>> > > K.
>> > >
>> > >
>> > > 2009/11/19 Tian Ma <>:
>> > >
>> > >
>> > > > Hi Kim,
>> > > >
>> > > > I have amended the attachment problem. Can you see the picture clearly now?
>> > > >
>> > > > Cheers,
>> > > > MT
>> > > >
>> > > >
>> > > > Kim Bale wrote:
>> > > >
>> > > >
>> > > > > Hi Tian,
>> > > > >
>> > > > > I can't really see what's wrong from the attached picture, it kind of
>> > > > > looks like a dirty blue splodge...
>> > > > >
>> > > > > K.
>> > > > >
>> > > > >
>> > > > > 2009/11/19 Tian Ma <>:
>> > > > >
>> > > > >
>> > > > >
>> > > > > > Hi Kim,
>> > > > > >
>> > > > > > When add my own island model to the oceanscene and of cource nodemask and shaders have been set to the model, I found that the reflection of the model on the ocean surface is not complete.
>> > > > > >
>> > > > > > Will you please tell me what caused this problem? And coule the problem be solved?
>> > > > > >
>> > > > > > Thank you!
>> > > > > >
>> > > > > > Cheers,
>> > > > > > Tian[/img]
>> > > > > >
>> > > > > > ------------------
>> > > > > > Read this topic online here:
>> > > > > > http://forum.openscenegraph.org/viewtopic.php?p=19879#19879
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > _______________________________________________
>> > > > > > osg-users mailing list
>> > > > > >
>> > > > > > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > _______________________________________________
>> > > > > osg-users mailing list
>> > > > >
>> > > > > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> > > > >
>> > > > >  ------------------
>> > > > > Post generated by Mail2Forum
>> > > > >
>> > > > >
>> > > >
>> > > >
>> > > > ------------------
>> > > > Read this topic online here:
>> > > > http://forum.openscenegraph.org/viewtopic.php?p=19896#19896
>> > > >
>> > > >
>> > > >
>> > > >
>> > > >
>> > > > _______________________________________________
>> > > > osg-users mailing list
>> > > >
>> > > > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> > > >
>> > > >
>> > > >
>> > > _______________________________________________
>> > > osg-users mailing list
>> > >
>> > > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> > >
>> > >  ------------------
>> > > Post generated by Mail2Forum
>> > >
>> >
>> >
>> > ------------------
>> > Read this topic online here:
>> > http://forum.openscenegraph.org/viewtopic.php?p=19901#19901
>> >
>> >
>> >
>> >
>> >
>> > _______________________________________________
>> > osg-users mailing list
>> >
>> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> >
>> >
>> _______________________________________________
>> osg-users mailing list
>>
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>  ------------------
>> Post generated by Mail2Forum
>
>
> ------------------
> Read this topic online here:
> http://forum.openscenegraph.org/viewtopic.php?p=20230#20230
>
>
>
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>


More information about the osg-users mailing list