[osg-users] [osgOcean] osgOcean also rendering with osgParticle?

Tian Ma tianxiao888 at foxmail.com
Tue Nov 24 03:52:49 PST 2009


Hi Kim:

   It is really my honor to test the new Version.

   The follow links are my test effect on my own computer:

1.We can see that: the sharp white around the boat is still there, although the around water looks transparent.

http://storage.openlab.net.cn/forums/2009-11-24/1981569/boat.JPG

2. When I look up to the boat under the ocean, the boat's color seems abnormal( purple ).

http://storage.openlab.net.cn/forums/2009-11-24/1981569/down_up.JPG

3.The foams around the island gone, and the water is just transparent around the shore.

http://storage.openlab.net.cn/forums/2009-11-24/1981569/foam.JPG


I will test the particle effect tomorrow morning on my work computer.

Cheers,
MT
  


Kim Bale wrote:
> Erik, Tian et al.
> 
> I committed some changes to the trunk last night that allow
> transparencies, and thus particle systems to work with the glare and
> depth of field effects
> (http://code.google.com/p/osgocean/source/detail?r=183). If you could
> test this functionality I would be grateful, it works fine on my
> machine, but I only tested it with a transparent quad and not particle
> systems but it appears Tian is having issues with the Multiple render
> target support.
> 
> Color buffer writes are now done to gl_FragData[0] and luminance/depth
> writes to gl_FragData[1]. You can see these changes in the water,
> terrain and default shaders.
> 
> Let me know how you get on.
> 
> Kim.
> _______________________________________________
> osg-users mailing list
> 
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> 
>  ------------------
> Post generated by Mail2Forum


------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=20227#20227







More information about the osg-users mailing list