[osg-users] broken osgconv.exe

Mourad Boufarguine mourad.boufarguine at gmail.com
Mon Nov 23 17:24:43 PST 2009


Hi Ted,

You can use the Dependency Walker (http://www.dependencywalker.com/) to
check the version number of the runtime, the dependencies were compiled
against.

I just tried it with the zlib and png dlls contained in "VisualStudio 9
(2008) SP1" prebuild dependencies (
http://www.openscenegraph.org/projects/osg/wiki/Downloads/Dependencies), and
I found that the release versions were compiled with the 9.0.30729 runtime,
which is actually "2008 SP1". The debug version, though, was compiled with
the 9.0.21022 runtime , which is the "2008" runtime. The zlib is used in
both ive and gz plugins. I don't see  how you get the message about the 2005
runtime dependency. Double check in the "output" window of VS that the zlib
and png dlls that are actually loaded are the good ones.

Regards,
Mourad

On Tue, Nov 24, 2009 at 1:21 AM, ted morris <ted.morris at gmail.com> wrote:

> credist_x86 VisualStudio 2005 (v8) runtimes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091124/ac86cde0/attachment.htm>


More information about the osg-users mailing list