[osg-users] SO version inconsistency

Robert Osfield robert.osfield at gmail.com
Thu Nov 19 07:31:20 PST 2009


Hi Alberto,

On Thu, Nov 19, 2009 at 2:42 PM, Alberto Luaces <aluaces at udc.es> wrote:
> I think we should remove Version, because things are not working
> now. What it is getting installed is the old Version file. I did the
> test of modifying it with some incorrect values and I could verify that
> those values were present on the file copied by the installation
> process.

Are you talking about an out of source build here?  An in source build
certainly works from the testing I've done, but I haven't tested an
out of source build yet.

> IMHO the fixes would be either to remove Version and put the output of
> the configured Version.in in its place, PROJECT_SOURCE_DIR, as my
> snippet showed, or to write an install rule to copy the configured
> Version.in after the build from the binary directory.

Removing Version from include/osg/Version would break the hand
maintained XCode projects, and force it to have it's own local copy of
Version which would be a backwards step all round.   So if we remove
Version then we really have to kick the XCode projects to touch as
well.

Assuming the problem you are seeing is down to an out of source build
then the short term solution is the simple change the location that
the autogenerated Version to be place in the PROJECT_SOURCE_DIR.
You've never said it explictly but I presume you mean this to get rout
the out of source build issue.

Robert.


More information about the osg-users mailing list