[osg-users] broken osgconv.exe

ted morris ted.morris at gmail.com
Tue Nov 17 14:53:54 PST 2009


Greetings, I'm having some trouble using osgconv.exe

after installing
 1)  openscenegraph-all-2.8.2-win32-x86-vc90-Release.zip<file:///V:/osg/OSG_OT_2.8.2/openscenegraph-all-2.8.2-win32-x86-vc90-Release.zip>
 2)  3rdParty_Win32Binaries_vc90sp1.zip

and setting the paths all works fine except for some of the pluggins

when I run osgconv --formats I get a fail dialog box popping up four
times indicating:

"This application has failed to start because MSVCR80.dll was not found.
Re-installing the application may
fix this problem"

for the following pluggins:

Plugin
C:\OpenSceneGraph\RELEASE\OpenSceneGraph-2.8.2\bin\osgPlugins-2.8.2/osgdb_curl.dll
not found.
Plugin
C:\OpenSceneGraph\RELEASE\OpenSceneGraph-2.8.2\bin\osgPlugins-2.8.2/osgdb_gz.dll
not found.
Plugin
C:\OpenSceneGraph\RELEASE\OpenSceneGraph-2.8.2\bin\osgPlugins-2.8.2/osgdb_ive.dll
not found.
Plugin
C:\OpenSceneGraph\RELEASE\OpenSceneGraph-2.8.2\bin\osgPlugins-2.8.2/osgdb_tiff.dll
not found.

I also get a similar dialog but for the libpng13.dll  with the osgdb_png
pluggin
Plugin
C:\OpenSceneGraph\RELEASE\OpenSceneGraph-2.8.2\bin\osgPlugins-2.8.2/osgdb_png.dll
not found.

I tried putting msvcr80.dll   in the osg pluggins folder,
in the binary pathed directory for 3rd party libraries:

C:\OpenSceneGraph\3rdParty\bin

or --

C:\OpenSceneGraph\3rdParty\lib
...

etc.,etc.,etc.

with no success.
I would like to be able to use these formats -- particularily ive and gz.

help or suggestions would be greatly appreciated.

thanks all,

T
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091117/d16aa420/attachment.htm>


More information about the osg-users mailing list