[osg-users] Particles problem

Maxim Gammer maxgammer at gmail.com
Mon Nov 16 02:52:05 PST 2009


Hi Robert,

I've tried 3 different ways.
1 - Both particles and emitter are children of the hidden/unhidden object
2 - Particles is the child of object, and emitter is in the root.
3 - Emitter is a child of the object and particles is in the root.

Hiding/unhiding is done by SetNodeMask. (FFFFFF or 000000)...

Max

2009/11/16 Robert Osfield <robert.osfield at gmail.com>

> HI Max,
>
> The particle system is set between several nodes, so which ones are
> you attempting to "hide"/"unhide" and how?
>
> Robert.
>
> On Mon, Nov 16, 2009 at 8:22 AM, Maxim Gammer <maxgammer at gmail.com> wrote:
> > Hello all,
> >
> > I came across the following situation.
> > Let us have an object with particles child and that object is hidden.
> > When we unhide this object we get picture 2 and 3.
> > Why particles don't dissapiar when the parent object is hidden? Why do
> they
> > accumulate? And how to deal with it, how to fix?
> >
> > P.S. Picture 1 shows how it shoud be.
> > --
> > Maxim Gammer
> >
> >
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> >
> >
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



-- 
Maxim Gammer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091116/5ca12cc3/attachment.htm>


More information about the osg-users mailing list