[osg-users] [forum] help with osgmovie

Ivan Salguero r_kenshin182 at hotmail.com
Wed Nov 11 10:41:41 PST 2009


Hi,

i try to play a movie in osg but the code osgmovie doesn't work i have some errors when i compile it

i think this need some class of plugin or SDL but i dont know where download this and how add to my project??? i need help

firsti have some problem with audiostream, and image but i download this again and i have this errors


prueba.obj : error LNK2019: símbolo externo "__declspec(dllimport) public: float __thiscall osg::Image::getPixelAspectRatio(void)const " (__imp_?getPixelAspectRatio at Image@osg@@QBEMXZ) sin resolver al que se hace referencia en la función _main
1>prueba.obj : error LNK2019: símbolo externo "__declspec(dllimport) public: class std::vector<class osg::ref_ptr<class osg::AudioStream>,class std::allocator<class osg::ref_ptr<class osg::AudioStream> > > & __thiscall osg::ImageStream::getAudioStreams(void)" (__imp_?getAudioStreams at ImageStream@osg@@QAEAAV?$vector at V?$ref_ptr at VAudioStream@osg@@@osg@@V?$allocator at V?$ref_ptr at VAudioStream@osg@@@osg@@@std@@@std@@XZ) sin resolver al que se hace referencia en la función _main
1>C:\Documents and Settings\adminmulti\Mis documentos\RealidadVirtual\Pory\OSGpr\Debug\OSGpr.exe : fatal error LNK1120: 2 externos sin resolver

Thank you!

Cheers,
Ivan

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=19508#19508







More information about the osg-users mailing list