[osg-users] OpenGL error 'out of memory'

Mourad Boufarguine mourad.boufarguine at gmail.com
Tue Nov 10 14:23:45 PST 2009


Hi,

I have the same problem as Cory. I am using svn/trunk. My last tests were
using rev 10710 approx (i am not sure).
My config is : Seven 64bits (OSG compiled in 32bits), 4GB of RAM, 2 x GTX280
Nvidia cards. I didn't have this problem before.


Strangely, I don't have the same problem with another config : XP 64bits
(OSG in 32bits), 12GB, Quadro 2700M Nvidia card.

Regards,

On Tue, Nov 10, 2009 at 3:39 PM, Glenn Waldron  wrote:

> You can monitor gfx mem usage with this tool:
> http://www.nuclearplayground.com/NuclearPlayground/
>
> Glenn Waldron : Pelican Mapping : http://pelicanmapping.com :
> +1.703.652.4791
>
>
>
> On Tue, Nov 10, 2009 at 9:36 AM, Cory Riddell  wrote:
>
>>  Nope. Running an ATI FireGL V7700 card.
>>
>> What are some of the legitimate reasons that OpenGL may be unable to
>> allocate memory? Is it likely to be video memory or some other type of
>> memory?
>>
>> Cory
>>
>>
>> Kim Bale wrote:
>>
>> Hi Cory,
>>
>> Are you using frame buffer objects and an nvidia card?
>>
>> Try running the osgprerender example and see if you get the same
>> error. If you do it's a nvidia driver bug. I've come this a number of
>> times and whilst there are legitimate reasons for getting the error in
>> my case it's always been a driver bug.
>>
>> Kim.
>>
>>
>>
>> 2009/11/10 Cory Riddell :
>>
>>
>>  When I render my scene, I'm getting this in the log:
>>
>>
>>
>>   Warning: detected OpenGL error 'out of memory' after RenderBin::draw(,)
>>
>>
>>  This is on a Windows XP machine with 4GB of RAM. I suspect it isn't
>> complaining about running out of that memory though. Is it video RAM
>> that I have run out of?
>>
>> Cory
>> _______________________________________________
>> osg-users mailing listosg-users at lists.openscenegraph.orghttp://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>      _______________________________________________
>> osg-users mailing listosg-users at lists.openscenegraph.orghttp://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091110/863a83c7/attachment.htm>


More information about the osg-users mailing list