[osg-users] OSG v2.8.0

Chris 'Xenon' Hanson xenon at alphapixel.com
Mon Nov 9 10:44:30 PST 2009


Jacob Armstrong wrote:
> I'm currently trying to upgrade from OSG-1.2 to OSG-2.8.0 to upgrade a
> process currently in place. I'm trying to load this new version from
> scratch on a Windows XP machine with VS 2003 .NET. I'm following the
> instructions from:
> http://www.openscenegraph.org/projects/osg/wiki/Support/PlatformSpecifics/VisualStudio
>  
> and have set up all of my environment variables, and I ran CMake to get
> my solution, and upon building the entire solution, I'm receiving over
> 250 link errors in the "plugins ogr" project similar to:
>  
> Linking...
> Creating library
> C:\CMHP\OpenSceneGraph-2.8.0_orig\OpenSceneGraph\lib\Debug\osgdb_ogrd.lib
> and object
> C:\CMHP\OpenSceneGraph-2.8.0_orig\OpenSceneGraph\lib\Debug\osgdb_ogrd.exp
> ReaderWriterOGR.obj : error LNK2001: unresolved external symbol "public:
> virtual enum CPLErr __thiscall GDALMajorObject::SetMetadataItem(char
> const *,char const *,char const *)"
> (?SetMetadataItem at GDALMajorObject@@UAE?AW4CPLErr@@PBD00 at Z
> <mailto:?SetMetadataItem at GDALMajorObject@@UAE?AW4CPLErr@@PBD00 at Z>)
> Does anyone know what I'm missing here?

  It would sound like GDAL is not available during compilation. OGR is the GIS image
loader that uses GDAL.

> Also, has the osgDem application
> gone away since OSG-1.2?

  It is broken out into VirtualPlanetBuilder, a separate SVN checkout and build:
http://www.openscenegraph.org/projects/VirtualPlanetBuilder

  You will need to finish the OSG build itself first, then build VPB.

> Thanks!
> Jake

-- 
Chris 'Xenon' Hanson, omo sanza lettere                  Xenon AlphaPixel.com
PixelSense Landsat processing now available! http://www.alphapixel.com/demos/
"There is no Truth. There is only Perception. To Perceive is to Exist." - Xen


More information about the osg-users mailing list