[osg-users] [osgPPU] I have an OSG app to which I would like to add a second render pass...

Mourad Boufarguine mourad.boufarguine at gmail.com
Wed Nov 4 17:03:39 PST 2009


Hi Art,

I Just want to say that ffmpeg do compile on windows (using *MSys+MinGW* but
not using Visual Studio). A tutorial building ffmpeg on windows can be found
here http://ffmpeg.arrozcru.org/wiki/index.php?title=Main_Page. You should
not have any problems linking  to it in Visual Studio.

Hopefully, you can download ffmpeg windows builds here
http://ffmpeg.arrozcru.org/autobuilds/. You will need to download a
"shared-dev" (to get .h and .lib even stdint.h and inttypes.h) and "shared"
(to get the dlls) packages. I am using these pre-built packages and they
work like a charm.

Regards,
Mourad


On Mon, Nov 2, 2009 at 7:28 PM, Art Tevs <arti_tevs at yahoo.de> wrote:

> Which plugin is exactly used, is actually not dependent on osgppu. It just
> uses osgDB to load an .avi file. In earlier versions of osg a quicktime
> plugin was used to play .avi files, right. I don't know exactly the version
> number, but in between there was a change to ffmpeg plugin. I am also not
> sure if ffmpeg is built on windows at all.
>
> So, if video example don't work, then just ignore it, if it is sufficient
> for you. It could be that you would require couple of additional libraries
> to built osg's video plugin on windows. Maybe search in forum or on the
> mailing list archives to find mor einfo, how to use video playback in osg on
> windows.
>
> cheers,
> art
>
>
>
> WyattEarp wrote:
> > I think I found the problem why the plugin isn't found... Is the
> > plugin for playing avi the QuickTime plugin?  If it is, it isn't
> > building built when I build OSG.  I ran CMake and see that the
> > QUICKTIME_LIBRARY and QUICKTIME_INCLUDE_DIR are NOTFOUND.  I assume
> > this is the reason the qt plugin isn't being built. Is that the case?
> > W
> >
> > On Mon, Nov 2, 2009 at 8:28 AM, Art Tevs <> wrote:
> >
> > > Hi Wyat,
> > >
> > >
> > > WyattEarp wrote:
> > >
> > > >
> > > > What is the
> > > > cudakernel project that Cmake generated?  Note of the files will open
> > > > in VS.
> > > >
> > > >
> > >
> > > This is the cuda example project. I have not checked if cmake does also
> generate valid VS files for cuda module in the example.
> > >
> > >
> > >
> > > >
> > > > Also, when I try to run the video example I get an error message
> saying that a plugin could not be found to read objects from
> Data/Images/video.avi and one that says the video.avi file could not be
> found.  I copied the Data directory underneath my bin directory and the
> other examples, except the cuda example and the osgppu_viewer example... the
> last one could be because I am not passing the correct args in.
> > > >
> > > >
> > >
> > > Please read README first. It says that you have to specify
> OSG_FILE_PATH before running the examples. Yes one way would be just to copy
> the Data directory under the bin path. Check that your osg plugins
> responsilbe for avi handling could also be found. Just to be on the safe
> side, you can copy all osgdb_*.dll into the bin directory where your
> examples are built.
> > > osgppu_viewer has to be started with a file path to any .ppu file. In
> those files the complete pipeline is stored, similar to .osg files.
> > >
> > > cheers,
> > > art
> > >
> > > ------------------
> > > Read this topic online here:
> > > http://forum.openscenegraph.org/viewtopic.php?p=19032#19032
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > osg-users mailing list
> > >
> > >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >
> > >
> > _______________________________________________
> > osg-users mailing list
> >
> >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> >
> >  ------------------
> > Post generated by Mail2Forum
>
>
> ------------------
> Read this topic online here:
> http://forum.openscenegraph.org/viewtopic.php?p=19061#19061
>
>
>
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091105/7f73ac2e/attachment.htm>


More information about the osg-users mailing list