[osg-users] Mac OS X Snow Leopard

Nico Kruithof nicokruithof at gmail.com
Tue Nov 3 01:00:58 PST 2009


Hi Paul,

I tried to compile osg/trunk as a static library on Snow Leopard this week
and it failed somewhere with a message about the quicktime library if I
remember correctly. I could build trunk again (shared or static) and send
the results to the cdash server if you are interested. It is a fresh snow
leopard install.

-- Nico

On Tue, Nov 3, 2009 at 9:29 AM, Stephan Huber <ratzfatz at digitalmind.de>wrote:

> Hi Paul,
>
> Paul Martz schrieb:
> > Thanks, not sure about a 2.8.3, but it's under consideration. Good to
> > know you're interested.
> >
> > I understand you can build 2.8.2 against the 10.5 SDK and still run on
> > Snow Leopard. My understanding is the changes to OSG for Snow Leopard
> > will allow someone to build OSG against the 10.6 SDK, is that right?
>
> Snow Leopard defaults to gcc 4.2 which is pickier than gcc 4.0 (the
> default for 10.5) The patches to Atomic + ReaderWriterQt fixes these
> issues with gcc 4.2.
>
> If you switch your xcode-projects to gcc 4.0 the current 2.8.x source
> builds fine for 10.4 on Snow Leopard.
>
> These patches are needed regardless what sdk you are targetting if you
> are using gcc 4.2. But they  even work for 10.5 / gcc 4.0 :)
>
> I can add an automatic build/compile test for the 2.8.x-branch here on
> my local machine, currently I am only monitoring osg-trunk and provide
> fixes back to Robert if necessary. But I didn't move to 10.6 with this
> machine.
>
> cheers,
> Stephan
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20091103/9b3fa612/attachment.htm>


More information about the osg-users mailing list