[osg-users] osgViewer crash loading textures under Windows Vista

Jakob Ruhe jakob.ruhe at gmail.com
Mon Nov 2 09:16:00 PST 2009


Instead of installing Visual Studio on the client computer you can
download and install the right vcredist package from Microsoft. The
one I think you need right now is:
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=200b2fd9-ae1a-4a14-984d-389c36f85647

On what format are the textures? The PNG plugin (osgdb_png) needs
libpng dll to be included, the TIFF plugin (osg_tiff) needs zlib dll
just to give you an example of files you also need.

As Erik den Dekker wrote, the dependency walker is a really good tool
to solve problems of this kind. Another way to get help is by starting
your application from the command prompt and set the OSG_NOTIFY_LEVEL
environmentvariable to DEBUG before.

I hope it helps. Good luck!

/Jakob Ruhe

2009/11/2 Philip Lamb <phil at eden.net.nz>:
> osgViewer (OSG v2.6, compiled under Windows XP SP3 with Visual Studio 2005
> SP1) crashes while loading textured models (e.g. cow.osg) when I run it on a
> clean install of Windows Vista SP2. Before I go through the
> pain of installing VS on this copy of Vista to run the debugger, are there
> any known gotchas running OSG compiled under XP in Vista?
>
> I'm tempted to just tell the customer to go back to running our app under XP
> but I'm sure this unfortunately won't be the last time we end up having to
> support a deployment on Vista.
>
> Any help or experiences much appreciated.
>
> Regards,
> Philip Lamb
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>


More information about the osg-users mailing list