[osg-users] problem with quadro cards & database pager / terrapageterrains = black tiles

Smelik, R.M. (Ruben) ruben.smelik at tno.nl
Mon Nov 2 01:22:27 PST 2009


Hi Vins,

I'm not so sure whether this is similar to an issue that I've had before
with OSG 2.8 / nvidia cards, but at least you can try it. I had black
(plain .ive) tiles showing up when the tile size was relatively large,
the geometry was using a VBO (instead of display lists) and the nvidia
control panel option Threaded optimization was enabled (turning it off
fixed it for me). But this was a couple of driver versions ago..

Kind regards,

Ruben

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of vin
baines
Sent: maandag 2 november 2009 10:07
To: osg-users at lists.openscenegraph.org
Subject: [osg-users] problem with quadro cards & database pager /
terrapageterrains = black tiles

Hi all,

Has anyone experienced problems with quadro cards and large terrains?
I'm loading a pretty big (~8gb) terrapage file (using Delta3D 2.3.0
which i think is built against osg 2.8.0), and on a standard nvidia card
it works fine.

Using exactly the same software, i've tested it on two different
machines with quadro cards and I get a combination of missing tiles or
tiles appearing black (but with a changing alpha value depending on
camera orientation). At different LODs the black tiles will change to a
proper tile, but if the tile was though to be missing it will never load
in.

It's not always the same tiles causing the problem, and it almost seems
that if i quit the app and re-run it up then the problem is less. its
really unpredictable. have tried turning all the graphics card options
(e.g. anisotropic filters etc) off and on and neither makes much
difference. The card has 512mb memory on it so wouldn't have thought
that would cause a problem...

Really confusing!! 

Any thoughts gratefully received!!

Vins

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=19012#19012





_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/disclaimer/email.html



More information about the osg-users mailing list