[osg-users] osgstereomatch not working on Windows, NVIDIA 8800

Thrall, Bryan bryan.thrall at flightsafety.com
Mon Sep 29 08:05:47 PDT 2008


J.P. Delport wrote on Monday, September 29, 2008 4:17 AM:

> Hi,
> 
> just recompiled latest svn (8953) and stereomatch and
> multiplerendertargets work OK. Linux NVidia 7400 Go (177.67).
> 
> sorry I can't help on Windows. Anyone else?

Thanks for checking. I'll try the latest NVidia driver release.

osgprerender does work just fine.

> J.P. Delport wrote:
>> Hi,
>> 
>> I will try later with the latest svn.
>> 
>> I have an older version (8504) and your posted command line for
>> stereomatch works on Linux here:
>> The top right is white, but the top left shows the disparity image.
>> 
>> osgmultiplerendertargets without params should display a light yellow
square.
>> 
>> I also post my warnings, they are similar to yours, you do not need a
>> specific enable for sampler2DRect, OSG does this.
>> 
>> It seems something is up with FBO and multiple targets. Can you check
if
>> osgprerender works properly? 
>> 
>> jp
>> 
>> Thrall, Bryan wrote:
>>> I've compiled OSG from svn HEAD (revision 8952)on Windows XP, but
>>> osgstereomatch isn't working. I have an NVIDIA 8800 card; I tried
driver
>>> version 169 and 175 with the same results.
>>> 
>>> I'm using OpenSceneGraph-Data from svn HEAD (revision 8952) as well.
>>> 
>>> When I run
>>> 
>>> osgstereomatch --left Images/dog_left_eye.jpg --right
>>> Images/dog_right_eye.jpg --min 0 --max 31 --window 9 --single
>>> 
>>> I see the two dog images with a flat red rectangle above them on the
>>> left and a flat white rectangle above on the right. Isn't this
example
>>> supposed to show the pixel difference between these images?
>>> 
>>> I tried without '--single' as well, and the only difference is the
red
>>> rectangle is blue. 
>>> 
>>> The only sign of something going wrong are warnings are printed from
>>> compiling the shaders with OSG_NOTIFY_LEVEL=DEBUG_FP (see attached
log).
>>> 
>>> Also, there was an additional warning that said sampler2DRect
couldn't
>>> be used without adding the following to the shaders:
>>> 
>>> #extension GL_ARB_texture_rectangle : enable
>>> 
>>> But adding that didn't resolve the problem.
>>> 
>>> On a possibly related note, osgstereoimage doesn't display anything,
and
>>> osgmultiplerendertargets only displays a blue rectangle (which I'm
not sure
>>> is correct). 
>>> 
>>> Is anyone else having similar problems? Any suggestions?
-- 
Bryan Thrall
FlightSafety International
bryan.thrall at flightsafety.com



More information about the osg-users mailing list