[osg-users] 2.6.1 release

Paul Martz pmartz at skew-matrix.com
Thu Sep 25 09:49:54 PDT 2008


> GenWrapper - no.  I've just done a rebuild on OSG 2.6.0 to 
> check, and didn't get a genwrapper error message.

I'm trying to reproduce this issue, and here's what I've found so far.

In 2.6.1, if I right click on the 'wrappers' target and select 'build', then
genwrapper is found and runs normally -- no error. However, if I remove the
genwrapper executable from my system PATH and try to build 'wrappers' again,
then I get an error like you describe. So, the first thing for you to check
is that the genwrapper executable is in your PATH. Did you build it from a
genwrapper svn tree? Where did you put the executable after you built it?

Compounding this mystery, you say you tried this on 2.6, but the wrappers
target didn't exist in 2.6. So I'm wondering: what is it exactly that you
are doing on 2.6.1 that generates the error? If you're right clicking on
'wrappers' and selecting 'build', there's no way you could do an equivalent
operation on 2.6 -- the 'wrappers' target didn't exist.

In general, you shouldn't need to build the 'wrappers' target, they should
already be built and checked in. However, I see they are out of date on
2.6.1 due to an osgTerrain change that I merged, so I'll work to update them
before I tag the release.

Thanks,
   -Paul




More information about the osg-users mailing list