[osg-users] A couple of Cmake issues with 2.6

Tomlinson, Gordon GTOMLINSON at overwatch.textron.com
Fri Sep 19 06:07:11 PDT 2008


Hi Philip
 
This is with the Cmake 2.4 or 2.6 using the OSG 2.6x branch
 
In the resultant vcproj files created many(most) projects end up with
both osg.lib and osgd.lib and some with osgGA.lib and osgGAd.lib and
those the use OpenThreads
 
Now I'm quite sure it is something we ( meaning me ) has screwed up some
how/were ;), as I said I'm a newbie when it comes to the minutia of
Cmake
 
the one thing we do is as a pre_fix to all the dll's and lib's  'tg_' to
stop any library/dll's clashes etc  with other projects in doing this we
probably 
 
 

Gordon

__________________________________________________________
Gordon Tomlinson

Product Manager 3D
Email  : gtomlinson @ overwatch.textron.com


__________________________________________________________
(C): (+1) 571-265-2612
(W): (+1) 703-437-7651

"Self defence is not a function of learning tricks 
but is a function of how quickly and intensely one 
can arouse one's instinct for survival" 
- Master Tambo Tetsura

 
 

________________________________

From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Philip
Lowman
Sent: Friday, September 19, 2008 8:32 AM
To: OpenSceneGraph Users
Subject: Re: [osg-users] A couple of Cmake issues with 2.6


On Thu, Sep 18, 2008 at 11:48 AM, Tomlinson, Gordon
<GTOMLINSON at overwatch.textron.com> wrote:


	found the issue with the
	
	cl : Command line warning D9025 : overriding
'/Fotg_OpenThreads.dir\Debug\' with '/Fo'
	cl : Command line error D8016 : '/fp:fast' and '/fp:except'
command-line options are incompatible
	Some command line option were gettng added incorrectly so rjust
removing them all solved that
	 
	Still not sure why I get osg.lib and osgD.lib in my debug linker
inputs


Could you elaborate a bit more?  Are you getting osg.lib and osgD.lib
inputs in your own CMake project or is this within the OSG?  What
version of OSG / CMake are you using?


-- 
Philip Lowman

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080919/64ba725f/attachment-0003.htm>


More information about the osg-users mailing list