[osg-users] CompositeViewer, update traversal, prerender branch

Robert Osfield robert.osfield at gmail.com
Fri Sep 19 00:59:05 PDT 2008


Hi Fabian,

I'm afraid you don't really say enough about the specifics of your
setup for others to know enough to help you.

With your View, do they are share the same GaphicsWindow?  How do you
setup the pre render step?  A slave Camera?  A Camera in the scene
graph, how do you grab the live Camera stream?

What version of the OSG, OS and hardware are you using?

Robert.

On Fri, Sep 19, 2008 at 4:26 AM, Fabian Bützow <buetz at uni-koblenz.de> wrote:
> Hi everybody,
>
> Ive got some problems with displaying the result of a prerender step in
> different views.
>
> The root node has two basic branches:
> a prerender branch that renders and processes a live camera image, and a
> main render branch, that has two subnodes. The output texture of the
> prerender step is applied to the subnodes in different ways. A View is set
> to each subnode to display the specific view of the scene. A third View is
> set to the root node to observe the overall behavior of the texture (applied
> to both subnodes).
>
> The problem is, that the Texture gets updated in the overall view, but not
> in the subnode views (it shows the initialised static texture, not even the
> updated camera image). When I set the scene data of the subnode views to the
> root, the texture gets updated, but the framerate drops. When i assign no
> View to the scene root, the prerender branch isnt traversed at all....As far
> as i know, the update traversal is called once per frame for a composite
> viewer, that should update the texture in all nodes. Please help me with
> that one.
>
> Cheers,
> Fabian
>
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list