[osg-users] Problems with multi-monitor and DrawThreadPerContext mode

Wojciech Lewandowski lewandowski at ai.com.pl
Thu Sep 18 09:04:59 PDT 2008


Hi Serge,

Try latest NVidia 177.92 beta drivers. They fixed my latest problems related 
to multithreaded use. Also may I suggest to stick to --SingleThreaded and
--CullDrawThreadPerContext modes while testing ? If everything goes fine 
then try other threading modes. Default threading mode is 
DrawThreadPerContext and is usually not a safest one to work with 
multi-monitor.

Wojtek

> Hi Serge,
>
>> Anyone has already seen such a problem ? Or anyone has some success with 
>> multi-monitor on WinXP and NVidia cards ?
>
> Search the archives for multi-monitor, Windows XP, NVidia. You'll find 
> extensive discussion in the past few months, with great investigation by 
> Wojtek Lewandowski. But the problem noted then should be worked around by 
> a double MakeCurrent call, so if you're indeed using OSG 2.6+ then perhaps 
> your problem is a different one.
>
> Here we use OSG on multi-monitor setups on both XP and Vista and for the 
> most part things work well, though we use the threading mode that OSG 
> chooses for us so I'm not sure it's the same one you use.
>
> Sorry I can't help more,
>
> J-S
> -- 
> ______________________________________________________
> Jean-Sebastien Guay    jean-sebastien.guay at cm-labs.com
>                                http://www.cm-labs.com/
>                         http://whitestar02.webhop.org/
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org 




More information about the osg-users mailing list