[osg-users] OpenSceneGraph Install issue

Robert Osfield robert.osfield at gmail.com
Sun Sep 14 01:38:02 PDT 2008


Hi Michael,

The path is LD_LIBRARY_PATH, not GD_LIBRARY_PATH.

/usr/local/lib64 really should be on your systems library path though,
just linux distro's haven't got around to fixing this yet, but perhaps
the next time you OS update you'll find that it is on the path.

Another way to add the path would be to just insert it into search
path by hand, adding /usr/local/lib64 into a file like:

   /etc/ld.so.conf.d/x86_64-linux-gnu.conf

The other route would be to just change CMake build so that it
installs in /usr/local/lib.

Robert.

On Sat, Sep 13, 2008 at 7:43 PM, Michael W. Hall <hallmw at att.net> wrote:
> I tried Bobs suggestion and added the /usr/local/lib64 directory to the
> GD_LIBRARY_PATH variable.
>
> I still get the same error.
>
> I am installing OSG and it is installing to /usr/local/lib64.  When I
> did $PATH the first time I did not see /usr/local/lib.  I modified
> my .bash_profile file and added it from there to the path.  I opened a
> terminal and got the same error.  Any idea what it could be?
>
> I could not get VPB to work so like you said I just tried osgversion to
> see if OSG was working.
>
> Michael
>
> On Sat, 2008-09-13 at 08:29 +0100, Robert Osfield wrote:
>> Hi Michael,
>>
>> VPB has no effect on osgversion, but if osgversion fails to run then
>> certainly VPB apps will fail as well.  I'm working on VPB and OSG both
>> on trunk, on a 64bit Intel quad core Kubuntu 7.10 system without
>> problems.
>>
>> Are you installing the OSG? Where has it installed to?  Does you
>> distro include the /usr/local/lib directories in its path?
>>
>> Robert.
>>
>> On Fri, Sep 12, 2008 at 11:22 PM, Michael W. Hall <hallmw at att.net> wrote:
>> > I got the latest trunk of OpenSceneGraph.  I was having trouble with
>> > VPB, but I tried to run "osgversion".  When I did I got the following:
>> >
>> > osgversion: error while loading shared libraries: libOpenThreads.so.11:
>> > cannot open shared object file: No such file or directory
>> >
>> > I have an AMD64 processor and Fedora Core 9 x86_64.  Could this be the
>> > reason my VPB is giving me this error?  I checked and the file in
>> > question exists.    I have tried making links from other libraries back
>> > to the where the files are in /usr/local/lib64.  I still get the same
>> > error. Any help appreciated.
>> >
>> > Michael
>> >
>> > _______________________________________________
>> > osg-users mailing list
>> > osg-users at lists.openscenegraph.org
>> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> >
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list