[osg-users] Problem with Optimizer - FLATTEN_STATIC_TRANSFORMS

Gerwin de Haan gerwindehaan at gmail.com
Fri Sep 12 07:21:44 PDT 2008


I quickly tried the above and can confirm the mentioned "improper
positioning" when viewing this model in osgviewer (the fabric of the office
chair is floating in mid-air, seperated from the rest of the model). I use
OSG 2.4, linux ubuntu 8.04. After I set "setenv OSG_OPTIMIZER OFF" the
problem disappears. However, when I used osgconv to convert the model to a
native .ive file, the model looks fine and does not seem to be influenced by
the OSG_OPTIMIZER settings. Maybe this helps,
Gerwin

On Fri, Sep 12, 2008 at 4:06 PM, Brian <osgscene at gmail.com> wrote:

> Hi Robert,Thanks for the quick response.  I am using OpenSceneGraph v2.6.0
> on Windows XP, with MSVC 7 and MSVC9 both have the problem.  When I say
> messed up I mean improper position and rotation of some parts in the model.
>
> I was loading a Collada(.dae) model using osgviewer.  An example model with
> this problem can be found here.
> http://sketchup.google.com/3dwarehouse/details?mid=54fc7050b3360467d810b14a81e12eca
>
> I ran the following command.
> osgviewer "Aeron Work Chair Fully Featured.dae"
>
> I then hacked removed FLATTEN_STATIC_TRANSFORM from
> the DEFAULT_OPTIMIZATIONS recompiled and reran the above command and the
> chair appeared with everything in proper position.
>
> Brian
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080912/58f3bfd5/attachment-0003.htm>


More information about the osg-users mailing list