[osg-users] Problem with building VirtualPlanetBuilder underOSG 2.6.0

Tomlinson, Gordon GTOMLINSON at overwatch.textron.com
Fri Sep 12 07:19:31 PDT 2008


Hi Robert

Perhaps the fact it only compiles against the trunk  should be at the top of the VPB page and hi-lighted ? 


Gordon

__________________________________________________________
Gordon Tomlinson

Product Manager 3D
Email  : gtomlinson @ overwatch.textron.com


__________________________________________________________
(C): (+1) 571-265-2612
(W): (+1) 703-437-7651

"Self defence is not a function of learning tricks 
but is a function of how quickly and intensely one 
can arouse one's instinct for survival" 
- Master Tambo Tetsura

 

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org [mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Robert Osfield
Sent: Friday, September 12, 2008 3:54 AM
To: OpenSceneGraph Users
Subject: Re: [osg-users] Problem with building VirtualPlanetBuilder underOSG 2.6.0

Hi Martin,

VPB trunk does not compile against OSG 2.6.0.  VPB trunk compiles against OSG trunk.  This is the third or fourth time in two weeks that exactly this topic has been raised.  Nowhere have I written or said that VPB trunk will compile against OSG 2.6.0, and the vpb website front page makes it clear that VPB trunk matches to OSG trunk.  It seems that users are full of wishful thinking and inability to follow mailing list traffic or read websites.

Yesterday I reached another milestone in my work on VPB, and I'll be wrapping this up with VPB dev release, which will match to an OSG dev release.  I will write to this list when this dev releases are made.

Robert.


On Fri, Sep 12, 2008 at 8:34 AM, Martin Hoffmann <StormbringerCSP at web.de> wrote:
> Hi all,
>
> I'm having trouble with building VirtualPlanetBuilder under OSG 2.6.0. 
> I use a SVN checkout of the VPB source code (revision 940) and the zip 
> file download of OSG. The first errors that occurs are
>
> ..\..\..\src\vpb\DataSet.cpp(1533) : error C2039: 'WriteHint' : is not 
> a member of 'osg::Image'
> ..\..\..\src\vpb\DataSet.cpp(1517) : error C2039: 'STORE_INLINE' : is 
> not a member of 'osg::Image'
>
> It seems there is a mismatch between the latest OSG version and the 
> current version of VPB. Is there a SVN revision that you would 
> recommend, or do I have to switch to an older version of OSG?
>
> Thanks
> Martin
> ______________________________________________________________________
> __ Schon gehört? Bei WEB.DE gibt' s viele kostenlose Spiele:
> http://games.entertainment.web.de/de/entertainment/games/free/index.ht
> ml
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.
> org
>
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



More information about the osg-users mailing list