[osg-users] Precipitation Effect

selman duatepe selmanduatepe at gmail.com
Wed Sep 10 06:07:41 PDT 2008


Hi Robert,

Thank you for quick response. I have three PrecipitationEffect active at one
time. I am trying for snow, rain, hail effect active at one time.

Selman

On Wed, Sep 10, 2008 at 3:35 PM, Robert Osfield <robert.osfield at gmail.com>wrote:

> Hi Selman,
>
> On Wed, Sep 10, 2008 at 1:13 PM, selman duatepe <selmanduatepe at gmail.com>
> wrote:
> > I have multiple precipitation effect objects. When I set the wind
> parameters
> > of precipitation effect objects, only one precipitation effect object
> > influence this wind parameters, the others are not.
> >
> > Anyone experienced about this problem?
>
> I haven't personally tried multiple osgParticle::PrecipitationEffect,
> when I wrote it I had in mind that only one would likely be active at
> any one time.
>
> Do you have multiple PrecipitationEffect active at one time?  What
> effect are you trying for?
>
> If you have multiple effects on at one time then perhaps lazy state
> updating on the uniform might be causing problems.  This is just a
> wild guess though.
>
> Robert.
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080910/2fd4a3e9/attachment-0003.htm>


More information about the osg-users mailing list