[osg-users] osgEphemeris

Viggo Løvli vigigio at hotmail.com
Tue Sep 9 06:30:01 PDT 2008


Hi Adrian,
 
I have experienced a similar problem.
 
First, check that you set a decent radius for the Ephemeris dome. Example: 5000 meters...
Ensure that your far-clip is at least that far away.
 
Ephemeris can be set to follow camera.
If you do not set this then you must have camera inside the Ephemeris dome.
 
If you set it to follow camera, then you are supposed to see it all the time.
 
I did however get into a struggle with it where the dome disappeared at seemingly random times.
It depended on where my camera was and the radius of the Ephemeris dome.
I learnt that if the Ephemeris dome radius was low (5000meters) then it would often pop away (as in not visible) when I moved my camera away from world centre. The problem increased the further away I went. At 10000meters from the world centre I would almost never see the Ephemeris dome.
 
Ephemeris was in fact following my camera, but it does this in a special way. It actually 'update' its position after culling is almost done. So at times it may be culled even though you say it shall follow camera.
 
The solution was to write a node-visitor that turns off culling for Ephemeris's root node and all of its child nodes.
 
I am not sure if this is the same problem as you have but you can try it.
 
Node visitor's apply function looks like this:
void DisableCullingVisitor::apply( osg::Node& node )
{
    node.setCullingActive( false );
    traverse( node );
}
Ensure that it is set up to traverse all children.
 
Hope it helps,
Viggo
 



Date: Tue, 9 Sep 2008 14:29:04 +0200From: 3dhelp at gmail.comTo: osg-users at lists.openscenegraph.orgSubject: [osg-users] osgEphemeris
Hi just come back to the good old osgEphemeris, i can not see any sky texture, what is wrong. do someone know the bug. adrian -- ********************************************Adrian Egli
_________________________________________________________________
Med MSN på mobilen holder du deg oppdatert.
http://info.mobile.no.msn.com/pc/default.aspx?ocid=30032
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080909/f9cb2296/attachment-0003.htm>


More information about the osg-users mailing list