[osg-users] performance issues with RTT

Steffen Kim mailto.stk at web.de
Fri Sep 5 09:34:25 PDT 2008


Thanks for the hints so far...

I gave you wrong information since I forgot that I take care of the NPOT-stuff myself.
The API I use later on needs POT-textures so I make sure that only POT-textures are rendered. So in fact my textures are normally 2048x1024.

I know that the performance issues are most certain a problem of the texture rendering since we have parts of the application where even huger amounts of (normal render-to-view) cameras are involved without slowing down everything as much. The scene is pretty simple too and runs smoothly without the RTT-cameras.
Back on Monday I will try to get some FPS-values for exactly the same camera-setup with and without RTT for different scene complexities (here in Germany the weekend begins now ;)).

What I just found out is that the texture sizes make a huge difference in rendering performance. With 256x256-textures my cameras hardly slow down the viewer at all. That's also an evidence that the problem has to be somewhere in the texture-creation-part. 
If this cannot be enhanced then I probably have to find a good balance between quality and speed.
But I still have hopes that there are better ways to improve my performance without having to sacrifice too much resolution-wise.

BTW: I'm running my stuff on a Xeon 5160 at 3GHz and 2GB RAM with a Radeon X1900 card.

Have a nice weekend,
Steffen



_______________________________________________________________________
Jetzt neu! Schützen Sie Ihren PC mit McAfee und WEB.DE. 30 Tage
kostenlos testen. http://www.pc-sicherheit.web.de/startseite/?mc=022220




More information about the osg-users mailing list