[osg-users] StereoMode doesn't work.

Martin Großer grosser.martin at gmx.de
Thu Sep 4 02:22:09 PDT 2008


Ok, try it.
But I think the problem is that I set the ReferenceFrame to ABSOLUTE_RF.
I do it because I would like a static camera. When I use RELATIVE_RF, I can
move the camera with my mouse. Or is this a mistake, when I set the
ReferenceFrame?

Martin

-----Ursprüngliche Nachricht-----
Von: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] Im Auftrag von Robert
Osfield
Gesendet: Donnerstag, 4. September 2008 11:12
An: OpenSceneGraph Users
Betreff: Re: [osg-users] StereoMode doesn't work.

Hi Martin,

I can't really guess as to whether there is bug in your code, or the
OSG as there is to little provided code context to know what is going
in in your app.   Try modifying an example like osgcompositeviewer to
do what you are after and see if that works, if it doesn't then send
this in to osg-users so that others can recreate the problem.

Robert.

On Wed, Sep 3, 2008 at 9:55 AM, Martin Großer <grosser.martin at gmx.de> wrote:
> Hello,
>
> I have a little problem with the stereo modus. I want to use the
anaglyphic
> stereo mode and it doesn't work, when I define a camera. A little Example:
>
> osg::DisplaySettings::instance()->setStereo(true);
>
osg::DisplaySettings::instance()->setStereoMode(osg::DisplaySettings::ANAGLY
> PHIC);
>
>
> That works fine, when I define a viewer and a Scene.
> Now, the anaglyphic doesn't work when I define a camera.
>
>
> osg::ref_ptr<osg::Camera> camera3 = new osg::Camera();
>
>
> I try to define a new DisplaySettings object.
>
>
> osg::DisplaySettings* ds = new osg::DisplaySettings;
> ds->setStereo(true);
> ds->setStereoMode(osg::DisplaySettings::ANAGLYPHIC);
> camera3->setDisplaySettings(ds);
>
>
> But this test failed.
>
>
> What is my mistake?
>
>
>
> Cheers, Martin
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




More information about the osg-users mailing list