[osg-users] useCursor

paul1492 at yahoo.com paul1492 at yahoo.com
Mon Sep 29 05:15:35 PDT 2008


I'm attempting to turn off the cursor using 
    osgViewer::Viewer::Windows windows;
   _viewer->getWindows(windows);
   for (osgViewer::Viewer::Windows::iterator itr = windows.begin(); 
                                                                itr != windows.end();
                                                               ++itr)
        (*itr)->useCursor(false);

and I seem to be getting this:

Got an X11ErrorHandling call disGpot laany =X11Err0oxr8H270a9n2d8lin g ceavlentl=0 dxispbl7a1y3=00200x8270
928 event=0xbfffcc60
Xlib: sequence lost (0x10034 > 0x35) in reply type 0x0!
Xlib: charsets ISO8859-1:GL and ISO8859-1:GL have the same CT sequence
Xlib: charsets ISO8859-10:GR and ISO8859-10:GR have the same CT sequence
Xlib: charsets ISO8859-15:GR and ISO8859-15:GR have the same CT sequence
Xlib: charsets GB2312.1980-0:GL and GB2312.1980-0:GL have the same CT sequence
Xlib: charsets JISX0212.1990-0:GL and JISX0212.1990-0:GL have the same CT sequence
Xlib: charsets KSC5601.1987-0:GR and KSC5601.1987-0:GR have the same CT sequence
Xlib: charsets CNS11643.1986-2:GL and CNS11643.1986-2:GL have the same CT sequence
Xlib: charsets CNS11643.1992-3:GR and CNS11643.1992-3:GR have the same CT sequence
Xlib: charsets CNS11643.1992-5:GL and CNS11643.1992-5:GL have the same CT sequence
Xlib: charsets CNS11643.1992-7:GL and CNS11643.1992-7:GL have the same CT sequence
Xlib: charsets BIG5-0:GLGR and BIG5-0:GLGR have the same CT sequence
Xlib: charsets BIG5-E1:GL and BIG5-E1:GL have the same CT sequence
Segmentation fault

I don't seem to have any problems with osgcatch which seems to do the same thing, but I am "newing" an osgViewer.  Any ideas what might be causing this?  I'm using OSG 2.6.  I do play with processor affinity/shielding, but turning this off doesn't seem to help.

Paul P.



      



More information about the osg-users mailing list