[osg-users] osg-users Digest, Vol 15, Issue 70

Quinn, Gary G.Quinn at tees.ac.uk
Fri Sep 26 01:23:07 PDT 2008


Hi Paul.
>>> GenWrapper - no.  I've just done a rebuild on OSG 2.6.0 to check,
and didn't get a genwrapper error message.
>> In 2.6.1, if I right click on the 'wrappers' target and select
'build', then
>>genwrapper is found and runs normally -- no error. 
>> ...
>> Did you build it from a genwrapper svn tree? Where did you put the
executable after you built it?
>> ..
>> there's no way you could do an equivalent operation on 2.6 -- the
'wrappers' target didn't exist.

The only difference at my side was that I downloaded 2.6.0 as a zip file
from the OSG downloads page, but I got 2.6.1 from the svn url you
specified.
With both versions, I used the same batch of 3rd party libs, and I used
VS's "batch build" to build everything.

>> In general, you shouldn't need to build the 'wrappers' target, they
should already be built and checked in. However, I see they are out of
date on 2.6.1 
That explains it, thanks Paul.  I guess I wouldn't normally need
genwrappers to compile OSG from source.
Gary.




More information about the osg-users mailing list