[osg-users] OverlayNode bug

Mathieu MARACHE mathieu.marache at gmail.com
Wed Sep 10 07:05:10 PDT 2008


Hi,

I happened to be testing the OverlayNode with transparent nodes and came
across a difficult to spot bug. There are in fact three techniques that you
can assign to an OverlayNode :

   1. osgSim::OverlayNode::OBJECT_DEPENDENT_WITH_ORTHOGRAPHIC_OVERLAY;
   2. osgSim::OverlayNode::VIEW_DEPENDENT_WITH_ORTHOGRAPHIC_OVERLAY;
   3. osgSim::OverlayNode::VIEW_DEPENDENT_WITH_PERSPECTIVE_OVERLAY;

Techniques 1 and 2 are producing expected results while technique 3 doesn't
handle the transparency

I haven't been able to spot where it goes wrong, I'm posting this in case
someone has a hint to where the problem lies.
-- 
Mathieu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080910/4a959179/attachment-0002.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OBJECT_DEPENDENT_WITH_ORTHOGRAPHIC_OVERLAY.jpg
Type: image/jpeg
Size: 7581 bytes
Desc: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080910/4a959179/attachment-0006.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: VIEW_DEPENDENT_WITH_ORTHOGRAPHIC_OVERLAY.jpg
Type: image/jpeg
Size: 7780 bytes
Desc: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080910/4a959179/attachment-0007.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: VIEW_DEPENDENT_WITH_PERSPECTIVE_OVERLAY.jpg
Type: image/jpeg
Size: 9261 bytes
Desc: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080910/4a959179/attachment-0008.jpg>


More information about the osg-users mailing list