[osg-users] osgviewerWX in 2.9.11, Ubuntu 11.04

Eduardo Poyart poyart at gmail.com
Sat Apr 30 08:32:41 PDT 2011


Thank you for the quick reply. I've asked on the wxWidgets mailing list as
well, and they said they made fixes for Unity (Ubuntu 11.04's desktop
manager). These fixes are in the wxWidgets 2.8.11 ubuntu package. I'll give
it a try. I was using wxWidgets 2.9.1 compiled from source, but it looks
like the most active wxWidgets development happens on the 2.8 branch.

Thanks
Eduardo


2011/4/30 Charles Cossé <ccosse at gmail.com>

> Hi Eduardo,
>
> Hopefully my response won't preclude anyone else from helping you too ...
>
> Did you re-compile/re-link your application?   Do you know whether wx got
> upgraded automatically on 11.04?  I am running 10.10 and wx version is 2.8
> ... though the default was 2.6 (wx version i'm talking) ... maybe you had
> 2.6 and ubuntu 11.04 upgraded you to wx-2.8?  If so then you'd clearly need
> to rebuild/relink ... try something like "cmake clean"  if your build file
> has a "clean" target defined, otherwise it might be using something
> out-of-date.
>
> Other ideas ... ummm ... does anything having to do with wx work?  try the
> demo! write a wx-hello-world and get something back.  keep poking it in
> different ways until the problem reveals itself.  good luck
>
> Charles Cosse
>
>
>
> On Fri, Apr 29, 2011 at 11:52 PM, Eduardo Poyart <poyart at gmail.com> wrote:
>
>> Hello
>>
>> I'm using OSG 2.9.11 and wxWidgets 2.9.1.
>>
>> I recently upgraded to Ubuntu 11.04.
>>
>> After I upgraded and rebuilt, osgviewerWX stopped working. The window
>> simply does not appear on screen.
>>
>> My application stopped working too. The viewer is never realized.
>>
>> Can anyone please point me where to investigate?
>>
>> Thanks
>> Eduardo
>>
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>
>
>
> --
> AsymptopiaSoftware|Software at theLimit
>           http://www.asymptopia.org
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20110430/9312b843/attachment-0004.htm>


More information about the osg-users mailing list