[osg-users] SubloadCallback on iOS: missing texture.

Alessandro Terenzi a.terenzi at gmail.com
Sat Apr 23 05:36:22 PDT 2011


Thank you Stephan,
I'll try to simplify my code and post it here later.

Alessandro

On Sat, Apr 23, 2011 at 11:00 AM, Stephan Huber <ratzfatz at digitalmind.de>wrote:

> Hi,
>
> it's hard to tell what's going wrong on your end without seeing the
> code. Texture-subloading works on IOS in general, if you are using an
> osg::Image which is attached to an osg::Texture and set it's dirty-flag.
>
> As a general note: TextureRectangle is not supported on OpenGL ES,
> there's an extension to use NPOT Texture2Ds on IOS, which is supported
> and used by osg.
>
> HTH,
> Stephan
>
> Am 22.04.11 22:54, schrieb Alessandro Terenzi:
> > I'm trying to use a SubloadCallback to update a NPOT texture in an app
> for
> > iOS. Actually the very same logic seems to work fine on a PC but on iOS
> it
> > is not working: I always get a flat-white color on the plane supposed to
> be
> > textured (I'm referring to the examples about SubloadCallbacks that can
> be
> > found in the forum and I'm using the latest tagged version of OSG
> 2.9.12).
> >
> > When I execute the app, I notice that the load method generates this
> > warning:
> >
> > *Warning: detected OpenGL error 'invalid operation' at After
> > Renderer::compile
> > *
> > and the subload method:
> >
> > *Warning: detected OpenGL error 'invalid operation' at after
> > RenderBin::draw(..)*
> > (repeated forever...)
> >
> > Is there something that must be done for iOS in order to successfully use
> > SubloadCallbacks? By the way, I also tried to override
> > the textureObjectValid(.) method so that it always returns true (as
> > suggested in another thread), this makes it to work on a PC but not yet
> on
> > iOS devices.
> >
> > Thank you for your help.
> > Alessandro
> >
> >
> >
> >
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20110423/2286747c/attachment-0003.htm>


More information about the osg-users mailing list