[osg-users] [osgPlugins] Error compiling fbx plugin

Andrea Martini martini.andrea at gmail.com
Fri Apr 22 08:33:07 PDT 2011


Hi to all,

i have tried also to compile osg 2.8.3 fbx plugin, with fbx sdk 2010.0.2.
In this case, i get only one compiling error :

..\..\..\..\src\osgPlugins\fbx\ReaderWriterFBX.cpp(233) : error C2661: 'fbxsdk_201002::KFbxImporter::Initialize': no overloaded function takes 2 arguments

The error line code is :

if (!lImporter->Initialize(utf8filename.c_str(), fileFormat))
        {
            return std::string(lImporter->GetLastErrorString());
        }

becouse Initialize accept only one input parameters.
Infact, from intellisense, i see :

virtual bool fbxsdk_201002::KFbxImporter::Initialize(const char * pFileName)

virtual bool fbxsdk_201002::KFbxImporter::Initialize(fbxsdk_201002::KFile *pFileName)

Is there a way to use fbx plugin with openscenegraph 2.8.3?

Thank you!

Andrea

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=38735#38735








More information about the osg-users mailing list