[osg-users] broken osgViewer header installation

Robert Osfield robert.osfield at gmail.com
Tue Apr 19 04:17:33 PDT 2011


HI Mattias,

Thanks for spotting this regression.  Could you make the changes that
fix the problem and post them to osg-submissions.  I'm just emarking
on a big osg-submissions purge so want to concentrate on this.

Cheers,
Robert.

On Tue, Apr 19, 2011 at 12:13 PM, Mattias Helsing <helsing72 at gmail.com> wrote:
> Hi all,
>
> I have discovered that the installation of the osgViewer headers got
> broken with rev 12208 and 12231. These are part of the Android
> integration (which is a great addition btw)
>
> The old cmake code went through some extra hoops to rebuild the source
> tree structure in the installation step, e.g. GraphicHandleX11 went
> into CMAKE_INSTALL_PREFIX/include/osgViewer/api/X11/. This is
> important since GraphicsWindowX11 includes
> <osgViewer/api/X11/GraphicsHandleX11>, not
> <osgViewer/GraphicsHandleX11> which is where it gets installed now.
>
> The reason that this hasn't been noticed is probably that the old
> headers are still installed to the correct place and still gets
> included.
>
> I'm suggesting to revert the old installation step only for platform
> specific header ( under include/osgViewer/api ) but keep other changes
> from 12208.
>
> cheers
> Mattias
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list