[osg-users] OSG and OpenGL ES 2.0

Ankur Gandhi ank.gandhi at tcs.com
Wed Apr 6 01:35:16 PDT 2011


Hi,

I am a new member of OSG. I am using 2.9.11 (latest developer release) version of OSG. In last few weeks, I used OSG over OpenGL. All the examples and Tutorials that are posted on the site have been very useful in learning OSG. Now, I want to use OSG over OpenGL ES 2.0. For this, I have modified cmake variables accordingly to emulate OpenGL ES on my ubuntu system. However I can't seem to get any example work. I get many different kinds of errors as below.


Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Warning: Material::apply(State&) - not supported.
Warning: TexEnv::apply(State&) - not supported.
Segmentation fault


After going through old posts, i found that these examples won't work directly over OpenGL es.

I would like to know if there are any examples available which i can use over OpenGL ES. It would really help me in figuring out if my OSG recompilation is successful and it will enable me to learn OSG over opengl ES.

Thank you!

Cheers,
Ankur

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=38244#38244








More information about the osg-users mailing list