[osg-users] svn trunk(9972) linking problem.

Robert Osfield robert.osfield at gmail.com
Mon Mar 30 09:31:12 PDT 2009


Hi Jose L.

Cedric's sent me a fix for this last week, but I've been too busy to do a
submissions purge so haven't got to it yet.   I'll get to it tomorrow or
Wednesday.

Robert.

On Mon, Mar 30, 2009 at 4:34 PM, Jose Luis Hidalgo <
joseluis.hidalgo at gmail.com> wrote:

> Hi All,
>
>    I was trying to compile the latest svn revision (9972), when the
> latest wrapper of osgAnimation::Bone failed to link because the
> "needLink" method is missing (no implementation). So I simple
> commented the method definition in order to compile:
>
> Index: include/osgAnimation/Bone
> ===================================================================
> --- include/osgAnimation/Bone   (revisión: 9972)
> +++ include/osgAnimation/Bone   (copia de trabajo)
> @@ -223,7 +223,7 @@
>         inline bool needToComputeBindMatrix() { return
> _needToRecomputeBindMatrix;}
>         virtual void computeBindMatrix();
>
> -        bool needLink() const;
> +        //bool needLink() const; // Not implemented.
>
>         void setNeedToComputeBindMatrix(bool state) {
> _needToRecomputeBindMatrix = state; }
>
>
> to whom it may concern :)
>
> Cheers,
>   JL.
>
>
> --
>  Jose L. Hidalgo Valiño (PpluX)
>  ---- http://www.pplux.com ----
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090330/1f8c3e63/attachment-0003.htm>


More information about the osg-users mailing list