[osg-users] [osgPlugins] Collada Commands

Adam Wise arwise at smcm.edu
Mon Mar 30 08:07:07 PDT 2009


rogerjames99 wrote:
> Adam Wise wrote: 
> >  
> > > rogerjames99 wrote:
> > > 
> > > > Adam Wise wrote: 
> > > > 
> > > > >  
> > > > > 
> > > > > > I set osg_notify_level to debug, and I recieved this when I ran osgconv. I honestly have no idea what this means, but at least it finds something.
> > > > > > 
> > > > > > GraphicsContext::setWindowingSystemInterface() 03571930 003D9198
> > > > > > 
> > > > > > Also, the collada plugin was built as far as I can tell. I attached the release log. Everything was located in:C:OpenSceneGraph-2.8.0buildsrcosgPluginsdaeosgdb_dae.dirRelease. Does that mean I made a mistake in setting things up?
> > > > > > 
> > > > > > ------------------
> > > > > > Read this topic online here:
> > > > > > http://forum.openscenegraph.org/viewtopic.php?p=9154#9154 (http://forum.openscenegraph.org/viewtopic.php?p=9154#9154) (http://forum.openscenegraph.org/viewtopic.php?p=9154#9154 (http://forum.openscenegraph.org/viewtopic.php?p=9154#9154))
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > _______________________________________________
> > > > > > osg-users mailing list
> > > > > > ()
> > > > > > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org (http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org) (http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org (http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org))
> > > > > > 
> > > > > > 
> > > > > > 
> > > > >   
> > > > > 
> > > >   Did you remember to run the INSTALL target as I mentioned in my last message. 
> > > > 
> > > > "Remember OSG cannot find plugins from the bin (build) directory, you need to run the INSTALL target (in both Release and Debug mode) as admiminstrator if you are on Vista. This will probably copy them into the right place under "/Program Files/OpenSceneGraph"."
> > > > 
> > > > 
> > > > Another point..If OSG cannot find ANY of the plugins then try setting the environment variable OSG_LIBRARY_PATH to C:Program FilesOpenSceneGraphlib or wherever the INSTALL target is putting the main osg libraries
> > > > 
> > > > Roger
> > > > 
> > > > ------------------
> > > > Post generated by Mail2Forum
> > > > 
> > >  
> > > 
> > > Ok. just to make sure, the INSTALL target is in the solution explorer (that's in Visual studio)  of the OpenSceneGraph.sln?
> >  
>  Yes
> 
> >  
> > >  Also, to install both debug and release you simply go into properties (of the install target) and change the configuration to debug/release?
> > > 
> >  
>  No, I think that just changes the particular set of build properties you are looking at. You normally select the solution configuration to build by using the "solution configuration" drop down list in the standard toolbar.
> 
> >  
> > > 
> > > I'm trying to make sure that the osg library path is found by using sysedit.
> > > 
> > > 
> >  
>  I normally use the Environment Variable editor on (My) Computer...Properties..Advanced.
> 
> Roger
> 
>  ------------------
> Post generated by Mail2Forum


A unique little issue comes up when I build with release, visual studio C++ prompts me for an executable for debug session. What should I select?

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=9457#9457








More information about the osg-users mailing list