[osg-users] Differences between osgconv at 1.2 and 2.2.0

Paul Martz pmartz at skew-matrix.com
Thu Mar 26 15:08:14 PDT 2009


I'm not sure what this has to do with osgconv? You say you're using the same
models. Please explain further why you mention osgconv.

If you crank up OSG_NOTIFY_LEVEL, do you get any more enlightening output?
Which stage of rendering is the source of the bottleneck on ATI? I assume
it's the draw stage.

Can you post a .osg model that exhibits the poor performance in osgviewer?

Is there a reason you're using OSG v2.2 and not v2.8? Have you tried v2.8 to
see if that resolved the problem?

Paul Martz
Skew Matrix Software LLC
http://www.skew-matrix.com
+1 303 859 9466

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Tom
Poehlman
Sent: Thursday, March 26, 2009 3:07 PM
To: osg-users at lists.openscenegraph.org
Subject: [osg-users] Differences between osgconv at 1.2 and 2.2.0

Hello,

We have a application that when compiled under version 1.2 libraries flys
fine on both Nvidia and ATI cards.  We recently recompiled application using
version 2.2.0 version of the libraries and it still flys fine on Nvidia
cards, but the frames per second get hammered on ATI cards.

I believe it has something to do with pbuffers, because the 2.2.0
compilation returns following error:

Failed to create pbuffer, failing back to normal graphics window.
Error:  Unable to create graphics context - cannot run compression.

We use exact same files and models and only difference is the OSG version.  

Are there any differences in the compiliation command Osgconv?


Thank you.

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=9330#9330





_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




More information about the osg-users mailing list