[osg-users] Fwd: Fwd: osganimate

ami guru dosto.walla at gmail.com
Thu Mar 26 14:01:08 PDT 2009


Thanks Cory,

It works now. Had to separate the export command in another line.

Yes i am running Ubuntu

*************Now****************

export
OSG_FILE_PATH=/home/sajjad/downloads/OpenSceneGraph/OpenSceneGraph-Data-2.6.0


*********************************


***************Before*******************
export
PATH=$PATH:$ACG_PATH:$H3D_

PATH:$H3DUTIL_INCLUDE_DIR:$HAPI_INCLUDE_DIR:$WM4_PATH:$OPENSCENEGRAPH_PATH:$OSG_FILE_PATH:$FTGL_PATH:


All piled up together with the other file paths

***************************************'**

Thanks for discussing that off-topic here

---------- Forwarded message ----------
From: Cory Riddell <cory at codeware.com>
Date: 2009/3/26
Subject: Re: [osg-users] Fwd: osganimate
To: OpenSceneGraph Users <osg-users at lists.openscenegraph.org>


 If you just type:
  osgviewer cessna.osg
or
  osgviewer glider.osg
do you see the cessna and the glider?

It sounds like the files aren't being loaded for some reason. That would
suggest either a permissions issue with the OSG_FILE_PATH directory, or
perhaps you don't have all the OSG modules available. Did you also make the
LD_LIBRARY_PATH change mentioned on that page (I'm assuming you are running
Unix).

When I run osganimate, I see the cessna and the glider circling above the
checkerboard.

Cory


ami guru wrote:

Thanks Cory,


I already have the path set as follows:



#OpenSceneGraph related flags
OPENSCENEGRAPH_PATH=/usr/local/share/OpenSceneGraph/bin
OSG_FILE_PATH=/home/sajjad/downloads/OpenSceneGraph/OpenSceneGraph-Data-2.6.0
OSG_NOTIFY_LEVEL=NOTICE



export
PATH=$PATH:$ACG_PATH:$H3D_PATH:$H3DUTIL_INCLUDE_DIR:$HAPI_INCLUDE_DIR:$WM4_PATH:$OPENSCENEGRAPH_PATH:$OSG_FILE_PATH:$FTGL_PATH:


It just render the checkbox plane , but no animation

But not working.

---------- Forwarded message ----------
From: Cory Riddell <cory at codeware.com>
Date: 2009/3/26
Subject: Re: [osg-users] osganimate
To: OpenSceneGraph Users <osg-users at lists.openscenegraph.org>


According to this page:

http://www.openscenegraph.org/projects/osg/wiki/Support/UserGuides/Examples
you need to have OSG_FILE_PATH set. Then "osganimate --overlay" should work.
It does for me.

Cory


ami guru wrote:

 Hello forum,


I am going through the osg examples and i have an issue with one of the
following

osganimate


What is the expected output of that example? - It should be some kind of
animation


I used the following commands , but getting no animation except the
rendering of the base.


 osganimate --persp ../../../OpenSceneGraph-Data-2.6.0/glider.osg


 osganimate --ortho ../../../OpenSceneGraph-Data-2.6.0/glider.osg



 osganimate --object ../../../OpenSceneGraph-Data-2.6.0/glider.osg


I must be missing something.


Any hint?


Regards
Sajjad

------------------------------

_______________________________________________
osg-users mailing
listosg-users at lists.openscenegraph.orghttp://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


------------------------------

_______________________________________________
osg-users mailing
listosg-users at lists.openscenegraph.orghttp://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090326/08601447/attachment-0003.htm>


More information about the osg-users mailing list